summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-02-09 22:27:32 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-02-09 22:28:50 +0000
commit48f3bc2e56cf2051e74015d3f40b66f334ac7702 (patch)
treec0a0f384e9b8c7bbc9871d9ecfe495955f01f0e9
parentnet-wireless/gnome-bluetooth: fix gnome2_env_reset typo (diff)
downloadgentoo-48f3bc2e56cf2051e74015d3f40b66f334ac7702.tar.gz
gentoo-48f3bc2e56cf2051e74015d3f40b66f334ac7702.tar.bz2
gentoo-48f3bc2e56cf2051e74015d3f40b66f334ac7702.zip
dev-embedded/raspberrypi-utils: Patch to drop -Werror flag
Closes: https://bugs.gentoo.org/923594 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--dev-embedded/raspberrypi-utils/files/raspberrypi-utils-werror.patch77
-rw-r--r--dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild4
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-embedded/raspberrypi-utils/files/raspberrypi-utils-werror.patch b/dev-embedded/raspberrypi-utils/files/raspberrypi-utils-werror.patch
new file mode 100644
index 000000000000..ddfce08d0407
--- /dev/null
+++ b/dev-embedded/raspberrypi-utils/files/raspberrypi-utils-werror.patch
@@ -0,0 +1,77 @@
+https://github.com/raspberrypi/utils/pull/69
+
+From 0bbef73e2f1df17c793152895cabac452a49981f Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Tue, 6 Feb 2024 21:36:08 +0000
+Subject: [PATCH] build: Only enable -Werror for debug builds
+
+-Werror is very unhelpful for distributions and end users as newer
+compilers will raise warnings that the maintainers may not see. The
+warnings should get reported upstream, but they shouldn't block users
+from using the software.
+
+Rather than drop the flag entirely, I have enabled it only for debug
+builds, e.g. -DCMAKE_BUILD_TYPE=Debug.
+
+Signed-off-by: James Le Cuirot <chewi@gentoo.org>
+---
+ dtmerge/CMakeLists.txt | 2 +-
+ eeptools/CMakeLists.txt | 2 +-
+ pinctrl/CMakeLists.txt | 2 +-
+ vclog/CMakeLists.txt | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/dtmerge/CMakeLists.txt b/dtmerge/CMakeLists.txt
+index f63648b..357889f 100644
+--- a/dtmerge/CMakeLists.txt
++++ b/dtmerge/CMakeLists.txt
+@@ -5,7 +5,7 @@ include(GNUInstallDirs)
+ #set project name
+ project(dtmerge)
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror")
++add_compile_options(-Wall -Wextra $<$<CONFIG:Debug>:-Werror>)
+
+ if (CMAKE_COMPILER_IS_GNUCC)
+ add_definitions (-ffunction-sections)
+diff --git a/eeptools/CMakeLists.txt b/eeptools/CMakeLists.txt
+index 3438255..90fc284 100644
+--- a/eeptools/CMakeLists.txt
++++ b/eeptools/CMakeLists.txt
+@@ -5,7 +5,7 @@ include(GNUInstallDirs)
+ #set project name
+ project(eeptools)
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror")
++add_compile_options(-Wall -Wextra $<$<CONFIG:Debug>:-Werror>)
+
+ if (CMAKE_COMPILER_IS_GNUCC)
+ add_definitions (-ffunction-sections)
+diff --git a/pinctrl/CMakeLists.txt b/pinctrl/CMakeLists.txt
+index 2178ee4..70427f2 100644
+--- a/pinctrl/CMakeLists.txt
++++ b/pinctrl/CMakeLists.txt
+@@ -1,7 +1,7 @@
+ cmake_minimum_required(VERSION 3.10...3.27)
+ include(GNUInstallDirs)
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror -pedantic")
++add_compile_options(-Wall -Wextra $<$<CONFIG:Debug>:-Werror> -pedantic)
+
+ #set project name
+ project(pinctrl)
+diff --git a/vclog/CMakeLists.txt b/vclog/CMakeLists.txt
+index 611f9dc..b7e57eb 100644
+--- a/vclog/CMakeLists.txt
++++ b/vclog/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ cmake_minimum_required(VERSION 3.10...3.27)
+
+-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Werror -pedantic")
++add_compile_options(-Wall -Wextra $<$<CONFIG:Debug>:-Werror> -pedantic)
+
+ #set project name
+ project(vclog)
+--
+2.43.0
+
diff --git a/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild
index 1c13aaaa6bdb..4668331a2b0a 100644
--- a/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild
+++ b/dev-embedded/raspberrypi-utils/raspberrypi-utils-0_p20240203.ebuild
@@ -27,6 +27,10 @@ RDEPEND="
S="${WORKDIR}/utils-${COMMIT}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-werror.patch
+)
+
src_configure() {
local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
cmake_src_configure