summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-06-03 19:32:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-06-03 20:15:09 -0400
commit4901013b1c91d3ce3815751eb9f7a664f16f2751 (patch)
tree94981311f310fa39f5520eee0672227d688536b3
parentgames-arcade/excido: EAPI7 bump (diff)
downloadgentoo-4901013b1c91d3ce3815751eb9f7a664f16f2751.tar.gz
gentoo-4901013b1c91d3ce3815751eb9f7a664f16f2751.tar.bz2
gentoo-4901013b1c91d3ce3815751eb9f7a664f16f2751.zip
games-arcade/excido: fix direct c++, add desktop file
Plus small style perference changes. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-arcade/excido/excido-0.1.5c-r4.ebuild (renamed from games-arcade/excido/excido-0.1.5c-r3.ebuild)23
1 files changed, 16 insertions, 7 deletions
diff --git a/games-arcade/excido/excido-0.1.5c-r3.ebuild b/games-arcade/excido/excido-0.1.5c-r4.ebuild
index 92458fcc17df..6dd286165633 100644
--- a/games-arcade/excido/excido-0.1.5c-r3.ebuild
+++ b/games-arcade/excido/excido-0.1.5c-r4.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit desktop toolchain-funcs
+
DESCRIPTION="Fast paced action game"
HOMEPAGE="https://icculus.org/excido/"
SRC_URI="https://icculus.org/excido/${P}-src.tar.bz2"
@@ -11,13 +13,14 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="dev-games/physfs
+DEPEND="
+ dev-games/physfs
+ media-libs/freealut
media-libs/libsdl[opengl]
- media-libs/sdl-mixer
- media-libs/sdl-ttf
- media-libs/sdl-image[png]
media-libs/openal
- media-libs/freealut"
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
RDEPEND="${DEPEND}"
PATCHES=(
@@ -26,13 +29,19 @@ PATCHES=(
)
src_compile() {
+ tc-export CXX
+
emake DATADIR=/usr/share/${PN}/
}
src_install() {
dobin ${PN}
+
insinto /usr/share/${PN}
- doins data/*
+ doins -r data/.
+
dodoc BUGS CHANGELOG HACKING README TODO \
- keyguide.txt data/CREDITS data/*.txt
+ data/{CREDITS,readme-jf-nebula_sky.txt} keyguide.txt
+
+ make_desktop_entry ${PN} Excido applications-games "Game;ArcadeGame"
}