summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-11-03 23:46:43 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-04 00:40:02 +0100
commit4904b314cebe14befad3417f344d22b023f3f4e0 (patch)
treeca33de6de4230adb2a93b2b6de49228432798efc
parentapp-misc/symlinks: clean up old. (diff)
downloadgentoo-4904b314cebe14befad3417f344d22b023f3f4e0.tar.gz
gentoo-4904b314cebe14befad3417f344d22b023f3f4e0.tar.bz2
gentoo-4904b314cebe14befad3417f344d22b023f3f4e0.zip
app-misc/egads: EAPI 6 bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--app-misc/egads/egads-0.9.5-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-misc/egads/egads-0.9.5-r1.ebuild b/app-misc/egads/egads-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..47f7d23b3a5e
--- /dev/null
+++ b/app-misc/egads/egads-0.9.5-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Entropy Gathering And Distribution System"
+HOMEPAGE="http://www.securesoftware.com/download_egads.htm"
+SRC_URI="http://www.securesoftware.com/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+EGADS_DATADIR=/var/run/egads
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^BINDIR/d' \
+ -e '/^LIBDIR/d' \
+ -e '/^INCLUDEDIR/d' \
+ "${S}"/Makefile.in || die "Failed to fix Makefile.in"
+ tc-export CC AR RANLIB
+}
+
+src_configure() {
+ econf \
+ --with-egads-datadir="${EGADS_DATADIR}" \
+ --with-bindir=/usr/sbin
+}
+
+src_compile() {
+ emake LIBDIR="/usr/$(get_libdir)"
+}
+
+src_install() {
+ keepdir ${EGADS_DATADIR}
+ fperms +t ${EGADS_DATADIR}
+ # NOT parallel safe, and no DESTDIR support
+ emake -j1 install \
+ BINDIR="${D}"/usr/sbin \
+ LIBDIR="${D}"/usr/$(get_libdir) \
+ INCLUDEDIR="${D}"/usr/include
+
+ dodoc README* doc/*.txt doc/*.html
+}