summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-11-25 20:17:32 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-11-25 20:17:32 +0200
commit4906865134736b5d8f9b13e60ff6b7462d6716a7 (patch)
tree18960f5059a5cd86c45b2eeb760ef4b5c065aaad
parentapp-admin/gopass-summon-provider: add 1.15.10 (diff)
downloadgentoo-4906865134736b5d8f9b13e60ff6b7462d6716a7.tar.gz
gentoo-4906865134736b5d8f9b13e60ff6b7462d6716a7.tar.bz2
gentoo-4906865134736b5d8f9b13e60ff6b7462d6716a7.zip
dev-python/idna: add 3.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/idna/Manifest1
-rw-r--r--dev-python/idna/idna-3.6.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/idna/Manifest b/dev-python/idna/Manifest
index 2cca1ab373ed..9bbd0102a95b 100644
--- a/dev-python/idna/Manifest
+++ b/dev-python/idna/Manifest
@@ -1,2 +1,3 @@
DIST idna-3.4.tar.gz 183077 BLAKE2B dd6c94104e17b441a7a63aec4e28f1969278996964c402865da8ad1040878539f798956e26532281cc44934544fd6fa33407949caf4a34fa2b48d7aafbb8fb5e SHA512 4060a9304c9bac04efdd0b97ec8f5aeb7e17417e767bf51c5dfc26605edad25ab67456cf6f6a3c5a9f32b8247e46f6343edfd8a6ffbcd6d1075c71e66d089d6a
DIST idna-3.5.gh.tar.gz 184973 BLAKE2B 68b39c00850663f5966ed1ee8c287a0026c441ed052b52aa6243cd595f6cd6fe62a7fe61b9b855c4ee851144fae2e88eda7bbd8405c66e37a9ad42ddc87cf361 SHA512 a806e4f96f2f1034dd634f3c86e80c6e7929a80c0773e4b2749466b691d38b94b6ea64994613cb5f8764754c1c9813eade4b74105f64233671b8eeaca7125bdc
+DIST idna-3.6.tar.gz 175426 BLAKE2B 962f2e1fdeb4abe28a198f2b469142df1ca336298dd4727c1d51871e747a17da0b946d09ef32b820b23e5fb103f5ab74234b31bd8540c52cf9d87e901326ca19 SHA512 8bea880d1b2fae1511f21381d73445f62e786c385eb949d2c39e611f71cb6f31f7e54927833a0f456e340857d384d960ab9e6ae31ac7481314254646de656cc0
diff --git a/dev-python/idna/idna-3.6.ebuild b/dev-python/idna/idna-3.6.ebuild
new file mode 100644
index 000000000000..863c51847bdb
--- /dev/null
+++ b/dev-python/idna/idna-3.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Internationalized Domain Names in Applications (IDNA)"
+HOMEPAGE="
+ https://github.com/kjd/idna/
+ https://pypi.org/project/idna/
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests unittest