summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-12 18:49:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-12 18:49:26 +0300
commit490e1c03166398fc63f736b5160d7416adb7f656 (patch)
treeb027f0ec31d51bc7b96516a4f43614493155ca3d
parentdev-python/jq: add 1.2.1, EAPI=8, enable tests (diff)
downloadgentoo-490e1c03.tar.gz
gentoo-490e1c03.tar.bz2
gentoo-490e1c03.zip
dev-python/munkres: add 1.1.4, EAPI=8, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/munkres/Manifest1
-rw-r--r--dev-python/munkres/munkres-1.1.4.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/munkres/Manifest b/dev-python/munkres/Manifest
index 130b8b17e3f1..2953568eef91 100644
--- a/dev-python/munkres/Manifest
+++ b/dev-python/munkres/Manifest
@@ -1 +1,2 @@
DIST munkres-1.1.2.tar.gz 11186 BLAKE2B 2ba5ab7ce85fdc06598829123ed334209f37c0fa4f82e863c78220db82e9b8b4c51c7369042bdac6e9b33b4d580145bdd37b5743f0b3f511141782588803cb0e SHA512 4a8b698f53812303f5020b4fc357f859a63d97370fe311d16ae959addd9cacee65667e430cd0d00496e423c1f0c7a3c8d4219ba49600a982de323fadd2c03bec
+DIST munkres-1.1.4.tar.gz 13777 BLAKE2B d783ac7a4fd55826ef3ddddd2ba82cf0499727e605a2414491af7dd9080193c53f1e48ed17dba9a462578bc958d3d9e2e1e413408143b4cfd0305f9cb3b6c517 SHA512 24ae7d04f4a6fe52f7bb9dc79bbee3e33425b85813382e2634e106a5d26d2d728ba8d34fab9390b7c3d651bc0e95214dcf9c94ac436636cd5b487a054b5a2c54
diff --git a/dev-python/munkres/munkres-1.1.4.ebuild b/dev-python/munkres/munkres-1.1.4.ebuild
new file mode 100644
index 000000000000..60083d981c89
--- /dev/null
+++ b/dev-python/munkres/munkres-1.1.4.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Module implementing munkres algorithm for the Assignment Problem"
+HOMEPAGE="https://pypi.org/project/munkres/ https://github.com/bmc/munkres"
+SRC_URI="https://github.com/bmc/munkres/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-release-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest