summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-07 09:13:38 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-07 09:16:21 +0100
commit49152a7d69d574430067f7f420f87ba39d1ca395 (patch)
tree8fdd8c2a25dd0bade8a514344e380abb97844318
parentgnustep-libs/highlighterkit: bump EAPI (diff)
downloadgentoo-49152a7d69d574430067f7f420f87ba39d1ca395.tar.gz
gentoo-49152a7d69d574430067f7f420f87ba39d1ca395.tar.bz2
gentoo-49152a7d69d574430067f7f420f87ba39d1ca395.zip
app-portage/eix: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-portage/eix/Manifest1
-rw-r--r--app-portage/eix/eix-0.35.2.ebuild103
2 files changed, 0 insertions, 104 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index 080ad2278408..10e8bd776dd6 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,2 +1 @@
-DIST eix-0.35.2.tar.xz 636616 BLAKE2B 22c9ce54bd612ff7b8a085d91727ee7b472b9c3ba71568f23b4cfc5e2c4d9b0a68e2df377d4c4101c53e193864418c11b0c76830b5b6044588dcf3882b164e3d SHA512 39ff4c4f31be3c40a17a77626c25550a3881d8c405ebd9e7a361252cb729f9c0fc40831bc41e503fdea9f05684ad0eaa1aceabba1c6e4067a33a8581bf5a9625
DIST eix-0.36.0.tar.xz 640820 BLAKE2B 952e6a354cc5fd1145ef36fed6047bc6f10dd7a51166028581e3b392be66b5df07eabb96cba362dc4f7a50fbe19e6ccb3744d30928c4763a91af21ad02cee38d SHA512 891e343b01d3887cbc7e61933b43e79949ff702dcd8ada2f15ff57a628dc6ebc9a4b6817d3aa3d814474db3131aefcbbf56cec2520868dcb2182cbee780125b5
diff --git a/app-portage/eix/eix-0.35.2.ebuild b/app-portage/eix/eix-0.35.2.ebuild
deleted file mode 100644
index 0971f52d7527..000000000000
--- a/app-portage/eix/eix-0.35.2.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools bash-completion-r1 flag-o-matic tmpfiles
-
-DESCRIPTION="Search and query ebuilds"
-HOMEPAGE="https://github.com/vaeth/eix/"
-SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="debug doc nls sqlite"
-
-DEPEND="
- nls? ( virtual/libintl )
- sqlite? ( >=dev-db/sqlite-3:= )"
-RDEPEND="${DEPEND}
- >=app-shells/push-2.0-r1
- >=app-shells/quoter-3.0_p2-r1"
-BDEPEND="
- app-arch/xz-utils
- nls? ( sys-devel/gettext )"
-
-pkg_setup() {
- # remove stale cache file to prevent collisions
- local old_cache=${EROOT}/var/cache/${PN}
- if [[ -f ${old_cache} ]]; then
- rm "${old_cache}" || die
- fi
-}
-
-src_prepare() {
- default
- sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
-
- sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
- -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
- -i src/eix-functions.sh.in || die
- sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
- -i src/Makefile.am || die
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=(
- $(use_enable debug paranoic-asserts)
- $(use_enable nls)
- $(use_with doc extra-doc)
- $(use_with sqlite)
- --without-protobuf
-
- # default configuration
- $(use_with prefix always-accept-keywords)
- --with-dep-default
- --with-required-use-default
-
- # paths
- --with-portage-rootpath="${ROOTPATH}"
- --with-eprefix-default="${EPREFIX}"
-
- # build a single executable with symlinks
- --disable-separate-binaries
- --disable-separate-tools
-
- # used purely to control/disrespect *FLAGS
- --disable-debugging
- --disable-new_dialect
- --disable-optimization
- --disable-strong-optimization
- --disable-security
- --disable-nopie-security
- --disable-strong-security
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- dobashcomp bash/eix
- dotmpfiles tmpfiles.d/eix.conf
-
- rm -r "${ED}"/usr/bin/eix-functions.sh || die
-}
-
-pkg_postinst() {
- tmpfiles_process eix.conf
-
- local obs=${EROOT}/var/cache/eix.previous
- if [[ -f ${obs} ]]; then
- ewarn "Found obsolete ${obs}, please remove it"
- fi
-}
-
-pkg_postrm() {
- if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
- rm -rf "${EROOT}/var/cache/${PN}" || die
- fi
-}