summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-01 09:34:37 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-01 14:15:44 +0100
commit492a2bb37e62cd4186cb354f5be72bf351801d98 (patch)
tree0299bd21d9dfcca6ebe29407ffd8d20bc1f854a6
parentdev-python/clang-python: Switch live to monorepo (diff)
downloadgentoo-492a2bb3.tar.gz
gentoo-492a2bb3.tar.bz2
gentoo-492a2bb3.zip
dev-python/lit: Switch live to monorepo
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lit/lit-10.0.0.9999.ebuild8
-rw-r--r--dev-python/lit/lit-9.0.1.9999.ebuild10
2 files changed, 7 insertions, 11 deletions
diff --git a/dev-python/lit/lit-10.0.0.9999.ebuild b/dev-python/lit/lit-10.0.0.9999.ebuild
index 32320b7920e1..05acb219e329 100644
--- a/dev-python/lit/lit-10.0.0.9999.ebuild
+++ b/dev-python/lit/lit-10.0.0.9999.ebuild
@@ -9,10 +9,8 @@ inherit distutils-r1 git-r3 multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-S=${WORKDIR}/${P}/utils/lit
-
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+S=${WORKDIR}/${P}/llvm/utils/lit
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -31,7 +29,7 @@ BDEPEND="
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' utils/lit
+ git-r3_checkout '' '' '' llvm/utils/lit
}
python_test() {
diff --git a/dev-python/lit/lit-9.0.1.9999.ebuild b/dev-python/lit/lit-9.0.1.9999.ebuild
index c9fb8cb28154..ca1cce6c00b2 100644
--- a/dev-python/lit/lit-9.0.1.9999.ebuild
+++ b/dev-python/lit/lit-9.0.1.9999.ebuild
@@ -9,11 +9,9 @@ inherit distutils-r1 git-r3 multiprocessing
DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
HOMEPAGE="https://llvm.org/"
SRC_URI=""
-S=${WORKDIR}/${P}/utils/lit
-
-EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
- https://github.com/llvm-mirror/llvm.git"
-EGIT_BRANCH="release_90"
+EGIT_REPO_URI="https://github.com/llvm/llvm-project.git"
+EGIT_BRANCH="release/9.x"
+S=${WORKDIR}/${P}/llvm/utils/lit
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
@@ -32,7 +30,7 @@ BDEPEND="
src_unpack() {
git-r3_fetch
- git-r3_checkout '' '' '' utils/lit
+ git-r3_checkout '' '' '' llvm/utils/lit
}
python_test() {