summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2024-04-03 10:06:16 -0400
committerCraig Andrews <candrews@gentoo.org>2024-04-03 10:07:42 -0400
commit4935eda0ec7b5fd684d3cbfffca10221e7ebe07d (patch)
tree75f992749b07bfbf7c82bfb9ce117179ecf520d1
parentwww-apache/mod_h2: add 2.0.27 (diff)
downloadgentoo-4935eda0.tar.gz
gentoo-4935eda0.tar.bz2
gentoo-4935eda0.zip
www-apache/mod_h2: drop 2.0.26
Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-2.0.26.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 0bd72df894d8..1ea7e2b55378 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -1,2 +1 @@
-DIST mod_h2-2.0.26.tar.gz 689313 BLAKE2B 472fed8dea63519c8bcf747a22d2cf081dd13180245925095bcc2e7a5c9764ed51235496f351d87fb6975d4d24f069c7fc93cf02ea42aebf6cf57dc6e33c5162 SHA512 73230bae718057e201a2580bdf28b2263637b52f414c2f6abf8e97f3b11472b649edd95c8c956a12473b567edd8e8a7eb5acf91f85621a7128a132f4891f9703
DIST mod_h2-2.0.27.tar.gz 692514 BLAKE2B c089644fada8fa2293a23d4af60ed23fd795b4ed2df170992ff89c898b663e83ad68080d083d58a5beab3a9e0ddbe56e35c99b8ba3551939bf68570652288abf SHA512 37be31f74bd9c54905c9be84bc7e6bd602604c113c2cb0af2eb9229a010763b04ce508a15a474b9193228ba6d075664879f42600253eb7ed92845285f20141f8
diff --git a/www-apache/mod_h2/mod_h2-2.0.26.ebuild b/www-apache/mod_h2/mod_h2-2.0.26.ebuild
deleted file mode 100644
index dddc92e83e4f..000000000000
--- a/www-apache/mod_h2/mod_h2-2.0.26.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit apache-module autotools
-
-MY_P="${PN/h2/http2}-${PV}"
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
- inherit git-r3
-else
- MY_PV="${PV/_rc/-rc}"
- MY_P="${PN}-${MY_PV}"
- S="${WORKDIR}/${MY_P}"
- SRC_URI="https://github.com/icing/mod_h2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="HTTP/2 module for Apache"
-HOMEPAGE="https://github.com/icing/mod_h2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="ssl"
-
-RDEPEND=">=net-libs/nghttp2-1.0
- >=www-servers/apache-2.4.48[-apache2_modules_http2,ssl?]"
-DEPEND="${RDEPEND}"
-
-need_apache2_4
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- default
-
- APACHE2_MOD_DEFINE="HTTP2"
- insinto "${APACHE_MODULES_CONFDIR}"
- newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
-}