summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-25 22:21:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-25 22:38:57 -0400
commit49373301bfa39f97c3b6486d2b5eb6060860eab2 (patch)
tree215a983a58e59f653a97676bc8d392bb6ff53230
parentapp-emulation/ruffle: sync live (diff)
downloadgentoo-49373301.tar.gz
gentoo-49373301.tar.bz2
gentoo-49373301.zip
media-gfx/ueberzugpp: add 2.8.5
Adds USE=sway, may seem like it should be "wayland" with these dependencies but afaik wayland has no real support for this and at best it will be specific to the window manager. Not adding a RDEPEND on sway given it may work with alternate sway-based WMs and is more of an optfeature if support is built. Don't use sway so I have not actually tried it (primarily use kitty protocol for this which works anywhere kitty runs). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-gfx/ueberzugpp/Manifest1
-rw-r--r--media-gfx/ueberzugpp/metadata.xml1
-rw-r--r--media-gfx/ueberzugpp/ueberzugpp-2.8.5.ebuild67
3 files changed, 69 insertions, 0 deletions
diff --git a/media-gfx/ueberzugpp/Manifest b/media-gfx/ueberzugpp/Manifest
index 06d33080cf37..b70b24278c9a 100644
--- a/media-gfx/ueberzugpp/Manifest
+++ b/media-gfx/ueberzugpp/Manifest
@@ -1,2 +1,3 @@
DIST ueberzugpp-2.8.3.tar.gz 42663 BLAKE2B 4889cc2ac7b22541c7d1c89d1a60cd6d091b4ce996f4c8b3166707cec236db3a28a72def0a9a9379d2fdb55cb0390c02e9996007abc3331da390a911843ebdcc SHA512 f3cc95e8b6ce06b30c2fcb749cb5cf0c77f982c3eb3e0e12fd34cad6820e9a7ae91ee3ff6f325edc7b764f69e33f2c9a8a2b4d34d3f22a87fb8c6e4f6dfed59e
DIST ueberzugpp-2.8.4.tar.gz 43906 BLAKE2B db36ea8dc74713673ac7ea9f62f12fd9d4f77e12030db3920eb193523599f6bd6f520faa821cacb18192c699439cae35f18bb208056f4c92d6f50b02f5fac014 SHA512 402887a8734bb034c3cd0975ddd6e584f865f6545726d5bf033f59552e0a026883dd845080cccee5340217d1782c70fb2e309bfda36207627d0455c5cc7b75db
+DIST ueberzugpp-2.8.5.tar.gz 48985 BLAKE2B 046e72786f51c0ece068a1046532ea7e5acfa01ee4880a9db8c9dd38aed229b66f56ee18831e82efd84fef20183bea160dc7f3194507e253aa46cad85f76a280 SHA512 f4d1ad45d121521ae158fe5c7ff845a7ac0150b4effdd0d856f9cab69c0f5bfeb34648113323a3c98412630c945c96825132e805b2bacb037a8c88762dd799ea
diff --git a/media-gfx/ueberzugpp/metadata.xml b/media-gfx/ueberzugpp/metadata.xml
index 19342d5360ec..407eee6aebee 100644
--- a/media-gfx/ueberzugpp/metadata.xml
+++ b/media-gfx/ueberzugpp/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="opencv">Use <pkg>media-libs/opencv</pkg> for additional image formats and OpenCL accelerated scaling</flag>
+ <flag name="sway">Enable support for <pkg>gui-wm/sway</pkg> on wayland</flag>
</use>
<upstream>
<remote-id type="github">jstkdng/ueberzugpp</remote-id>
diff --git a/media-gfx/ueberzugpp/ueberzugpp-2.8.5.ebuild b/media-gfx/ueberzugpp/ueberzugpp-2.8.5.ebuild
new file mode 100644
index 000000000000..3d6109418aae
--- /dev/null
+++ b/media-gfx/ueberzugpp/ueberzugpp-2.8.5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Drop in replacement for ueberzug written in C++"
+HOMEPAGE="https://github.com/jstkdng/ueberzugpp/"
+SRC_URI="https://github.com/jstkdng/ueberzugpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X opencv sway"
+
+RDEPEND="
+ dev-cpp/tbb:=
+ dev-libs/glib:2
+ dev-libs/libfmt:=
+ dev-libs/openssl:=
+ dev-libs/spdlog:=
+ media-gfx/chafa
+ media-libs/libsixel
+ media-libs/vips:=
+ sys-apps/util-linux
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-image
+ )
+ opencv? ( media-libs/opencv:= )
+ sway? ( dev-libs/wayland )
+ !media-gfx/ueberzug"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/cli11
+ dev-cpp/ms-gsl
+ dev-cpp/nlohmann_json
+ X? ( x11-base/xorg-proto )
+ sway? ( dev-libs/wayland-protocols )"
+BDEPEND="
+ sway? (
+ dev-util/wayland-scanner
+ kde-frameworks/extra-cmake-modules
+ )"
+
+src_configure() {
+ CMAKE_BUILD_TYPE=Release # install target wants this
+
+ local mycmakeargs=(
+ -DENABLE_OPENCV=$(usex opencv)
+ -DENABLE_SWAY=$(usex sway)
+ -DENABLE_TURBOBASE64=no # not packaged
+ -DENABLE_X11=$(usex X)
+ -DFETCHCONTENT_FULLY_DISCONNECTED=yes
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # not handled by cmake, but upstream creates the pp symlink in their
+ # self-maintained AUR package and some scripts like ytfzf look for it
+ dosym ueberzug /usr/bin/${PN}
+}