summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-28 19:50:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-28 20:13:37 +0200
commit494877a95c300c3fbe5026e18e23a08011d20d2c (patch)
treee764aa20c56179303258a7f45a6fe9f6f30a1432
parentxfce-base/xfce4-session: Bump to 4.18.2 (diff)
downloadgentoo-494877a95c300c3fbe5026e18e23a08011d20d2c.tar.gz
gentoo-494877a95c300c3fbe5026e18e23a08011d20d2c.tar.bz2
gentoo-494877a95c300c3fbe5026e18e23a08011d20d2c.zip
xfce-base/libxfce4ui: Bump to 4.18.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.18.3.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 41b3ef0921ed..d7c9ad0f2809 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1 +1,2 @@
DIST libxfce4ui-4.18.2.tar.bz2 901949 BLAKE2B 17bf0541646735ec54da5f322d858896fa2fd132fe93864372a67d4936b4467def749f4a0dd4f3d23ecb7a2b3843367f88ccf74b7e040e7ad6f6c15fec45055f SHA512 758466e2e3096791b99e1a00c9f499d95327581ad336fc1ab0d51e3d150206d522f44c2e6053b0032499dd0cb337510cf6940dc77499cef3ecbb484de7787457
+DIST libxfce4ui-4.18.3.tar.bz2 905070 BLAKE2B 0ed4bdaa1135d22d5155e22d8ecaaca2b2be714a097f26fc0388ea4bfdf39d8bf854e85ee1ace590000000d81034e414a7a0782ba3218e09901a1e0afdaf5fbe SHA512 697d883352189426b36d6c06254404b1dd2ba5f9630691b7dfddb2496d7b0233e807485155ead02dfaa73dc543eee7d8e459dc72ec56f646ec020fc9142edd28
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.18.3.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.18.3.ebuild
new file mode 100644
index 000000000000..31a8ab010145
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.18.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4ui/start
+ https://gitlab.xfce.org/xfce/libxfce4ui/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="glade +introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3[introspection?,X]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}