summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-29 06:19:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-29 07:12:08 +0200
commit494c077984d443466455726a45f6b9d1b4d38426 (patch)
tree75068f71af44082636c63010b9932c2e21ef236b
parentdev-python/meson-python: Bump to 0.13.2 (diff)
downloadgentoo-494c077984d443466455726a45f6b9d1b4d38426.tar.gz
gentoo-494c077984d443466455726a45f6b9d1b4d38426.tar.bz2
gentoo-494c077984d443466455726a45f6b9d1b4d38426.zip
dev-python/joblib: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/joblib-1.2.0.ebuild1
-rw-r--r--dev-python/joblib/joblib-1.3.0.ebuild57
3 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index 8873889b7f93..39974800136e 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1 +1,2 @@
DIST joblib-1.2.0.gh.tar.gz 345345 BLAKE2B e18be536054829057ff320eda320a7548434108b3fc6c92a03df73dc68e093d039c656c1d674ea26fb6419bdfc39d26cfc28236a6bfbf0dcbf3ace7e52b0c829 SHA512 de882f2ff8dd936b4f98352b9ee1cc56c3a734f215a74257cf90a25736afd9e6b93e6538929b7a29f5956e6fccbdfcbf8b39c8fd68035a8857721f7a76066133
+DIST joblib-1.3.0.gh.tar.gz 357076 BLAKE2B d14c71deba922fe9e9caabb35f60aeeac505e2b3fde1b87b12f998086aac91ef337af360320f5f5ac8e2e3c05a6b77d46e0b2f794932f8ecbcca2ecd907028b3 SHA512 3264f3fdf66095302c37c32cb43221c686c62646a01dbc14233c588d36e9dd13132e8b4cb0b48d2add6cdf5bb86e7c2e6dac6664a9bd22de2035ded28f61a06c
diff --git a/dev-python/joblib/joblib-1.2.0.ebuild b/dev-python/joblib/joblib-1.2.0.ebuild
index e97c038a7f9a..13027f0f851c 100644
--- a/dev-python/joblib/joblib-1.2.0.ebuild
+++ b/dev-python/joblib/joblib-1.2.0.ebuild
@@ -39,7 +39,6 @@ python_prepare_all() {
-e 's:from \.externals ::' \
-i {} + || die
- # https://github.com/joblib/joblib/issues/1115
sed -e 's:test_parallel_call_cached_function_defined_in_jupyter:_&:' \
-i joblib/test/test_memory.py || die
diff --git a/dev-python/joblib/joblib-1.3.0.ebuild b/dev-python/joblib/joblib-1.3.0.ebuild
new file mode 100644
index 000000000000..acfab4db2d7a
--- /dev/null
+++ b/dev-python/joblib/joblib-1.3.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Tools to provide lightweight pipelining in Python"
+HOMEPAGE="
+ https://joblib.readthedocs.io/en/latest/
+ https://github.com/joblib/joblib/
+ https://pypi.org/project/joblib/
+"
+SRC_URI="
+ https://github.com/joblib/joblib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/loky[${PYTHON_USEDEP}]
+"
+# joblib is imported by setup.py so we need ${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # https://github.com/joblib/joblib/issues/1115
+ joblib/test/test_memory.py::test_parallel_call_cached_function_defined_in_jupyter
+ # unexpectedly pickleable?
+ joblib/test/test_hashing.py::test_hashing_pickling_error
+)
+
+python_prepare_all() {
+ # unbundle
+ rm -r joblib/externals || die
+ sed -e "/joblib.externals/d" -i pyproject.toml || die
+ find -name '*.py' -exec \
+ sed -e 's:\(joblib\)\?\.externals\.::' \
+ -e 's:from \.externals ::' \
+ -i {} + || die
+
+ distutils-r1_python_prepare_all
+}