summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-05-28 09:23:55 -0400
committerMatt Turner <mattst88@gentoo.org>2022-05-28 09:24:49 -0400
commit494f8cde1b54416280eccd04d444f6271a5a093d (patch)
treeefed86807e3618be6027f53140aeb82911468f9e
parentwww-plugins/chrome-binary-plugins: automated update (104.0.5083.0_alpha) (diff)
downloadgentoo-494f8cde.tar.gz
gentoo-494f8cde.tar.bz2
gentoo-494f8cde.zip
sci-geosciences/gnome-maps: Version bump to 42.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-42.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index fdd3070ddc07..79482eba62a8 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,3 +1,4 @@
DIST gnome-maps-41.4.tar.xz 2187076 BLAKE2B bb35925d1b69d50c65e3ffe68386242b776c2089bea3b2bfe88383f1a8fba4045474a1c8fc1c5d07a5b207ad953396d3a76af77fbdf984d286b5e242f9eea78f SHA512 605de671f85ae38a8dc79e58594f2170215e8a070377b1d9ebded9891425898bb40613f6acee1c95f5ea2e0d95e6a8c25757665a5aa890831325701b1abbc8fa
DIST gnome-maps-42.0.tar.xz 2315828 BLAKE2B dca0f7845b257780701186adf3408cf41797b235969dadf1fe73003b9e52b3ab26d39f8190336616d697bf87eafb2e1abd05a4da9de4837153237fd08e382854 SHA512 888caa6418a8afea6d334b90f28eb865e3955c0534df25d458e6b3a063944d09c46a3775a3d4953a968980446f2be69bd0c5c4183b3fc8419ed1f7bbb812429c
DIST gnome-maps-42.1.tar.xz 2315924 BLAKE2B a2bf6eb8bef69c80febeffc29294840b701a207d5b6479dabae4daa13de4b5325319314bb755d44fa5ec41bae397af1e642950553b6c36be29f8a68109c15b3f SHA512 a01bf5eefa541542930e53750ac216cd93e4b409a171b57ed18525020cd2dc55db596ab68885ab9d607999c971f8e4ec2b746507157aab32b863a17a222a6fc2
+DIST gnome-maps-42.2.tar.xz 2317216 BLAKE2B 2a485c15ad203fb4518541a60231a0ed756ca3cf7abc524911a2294b3503077d0974ecc8690073e3967241a8769687a1524506a42bea8c473192128cd2ae9bb7 SHA512 87da3b6850d1a7ca4d90781089800f082026406555773ea1a9bac376b41e480eb4b5a10ec3f0a2f85de521e847489f4e761117a08e7125447aab7acf05720c1f
diff --git a/sci-geosciences/gnome-maps/gnome-maps-42.2.ebuild b/sci-geosciences/gnome-maps/gnome-maps-42.2.ebuild
new file mode 100644
index 000000000000..a8c7b50184bb
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-42.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ x11-libs/pango[introspection]
+ >=dev-libs/gjs-1.66.0
+ >=dev-libs/gobject-introspection-0.10.1:=
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libhandy-1.5.0:1=
+ >=dev-libs/libgee-0.16:0.8[introspection]
+ >=dev-libs/folks-0.10:=
+ >=sci-geosciences/geocode-glib-3.15.2[introspection]
+ >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.7.90:0.7[introspection]
+
+ app-crypt/libsecret[introspection]
+ dev-libs/libgweather:4=[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:2.4[introspection]
+ net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}