summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-28 00:58:51 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-01-28 00:58:51 +0100
commit495316dea07a17c6b53a0c0981dede6a5e4a7dad (patch)
tree781713d62df8d577ad5d083bd95982e063fb1eaf
parentx11-wm/vtwm: EAPI bump (diff)
downloadgentoo-495316de.tar.gz
gentoo-495316de.tar.bz2
gentoo-495316de.zip
x11-terms/root-tail: EAPI bump
Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--x11-terms/root-tail/root-tail-1.2-r4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-terms/root-tail/root-tail-1.2-r4.ebuild b/x11-terms/root-tail/root-tail-1.2-r4.ebuild
new file mode 100644
index 000000000000..465304ebd74e
--- /dev/null
+++ b/x11-terms/root-tail/root-tail-1.2-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Terminal to display (multiple) log files on the root window"
+HOMEPAGE="http://oldhome.schmorp.de/marc/root-tail.html"
+SRC_URI="http://oldhome.schmorp.de/marc/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="kde debug"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="x11-misc/imake
+ app-text/rman
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-misc/gccmakedep"
+
+src_prepare() {
+ use kde && eapply "${FILESDIR}"/${P}-kde.patch
+ default
+}
+
+src_configure() {
+ xmkmf -a
+}
+
+src_compile() {
+ sed -i 's:/usr/X11R6/bin:/usr/bin:' Makefile || die "sed Makefile failed"
+ use debug && append-flags -DDEBUG
+ emake \
+ CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man
+ dodoc Changes README
+}