summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-04-01 15:41:45 +0100
committerMarek Szuba <marecki@gentoo.org>2019-04-01 15:51:20 +0100
commit495bf98dba8ac687dd73f39f3e6aa0f1e764850d (patch)
tree3b626e18db74a9014c6385ea7cb70bf02757ad32
parentdev-java/xz-java: clean up old. (diff)
downloadgentoo-495bf98dba8ac687dd73f39f3e6aa0f1e764850d.tar.gz
gentoo-495bf98dba8ac687dd73f39f3e6aa0f1e764850d.tar.bz2
gentoo-495bf98dba8ac687dd73f39f3e6aa0f1e764850d.zip
dev-python/pyicu: bump to 2.3
This is the first version of PyICU to support ICU-64 Closes: https://bugs.gentoo.org/682064 Closes: https://bugs.gentoo.org/682200 Signed-off-by: Marek Szuba <marecki@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
-rw-r--r--dev-python/pyicu/Manifest1
-rw-r--r--dev-python/pyicu/pyicu-2.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyicu/Manifest b/dev-python/pyicu/Manifest
index 5eb6f7c96914..1d214a1098c6 100644
--- a/dev-python/pyicu/Manifest
+++ b/dev-python/pyicu/Manifest
@@ -1,2 +1,3 @@
DIST PyICU-2.0.2.tar.gz 194525 BLAKE2B 9ef0c5defdebfd65760c6de5782308eac5433fd8474b9802ed1a79db494a259c88f22286b0a98b25bdcec22cbf78a3a7e411d8a9a7a81b07a2112204d6b44141 SHA512 b3715a0f88227a41b56988ee98e795fe398867c2788b2929e0d4f83bfe9519ff01648eb23cfe8d1d9073930a4d7220c0ad5ebcf2652d8fa3ec43e4c4a4bcf091
DIST PyICU-2.2.tar.gz 211135 BLAKE2B f56e590ec4aefb61b6d3b37c807a018698ee97a632ccdd08f5f879cdccc576a6da1d31bb0ede54813be640ebdf600fe522a5c35ff417ac8e157c516a1b3bd7cc SHA512 30cce676fa502040e20fd4303baeebf0d83730abfedf79fdf3b69c1a3b52032a3337168b6e8902286dd4b46dda5bf894795995c6f1ef2a237fdabc374bb5ffcf
+DIST PyICU-2.3.tar.gz 214710 BLAKE2B ef676cce089962d16a88193e7aa2ffec739086e5bbef201c8779a372a5876bbb1e63e5e92a7c89c879b91f063e90d4fdb16a1967dff5f2ef658cde95f9fdca6c SHA512 2bdbc7fb7c83e58c9d0d53dadf8fef92d8dec02e9eefebc75bac43c19f008ef2a3219d41b62c426c41a055bb4530b2f7ef567162660d6021b8d2bf9e99090f94
diff --git a/dev-python/pyicu/pyicu-2.3.ebuild b/dev-python/pyicu/pyicu-2.3.ebuild
new file mode 100644
index 000000000000..20c7f98b97f7
--- /dev/null
+++ b/dev-python/pyicu/pyicu-2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="PyICU"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python bindings for dev-libs/icu"
+HOMEPAGE="https://github.com/ovalhub/pyicu"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/icu:="
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest
+ dev-python/six )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(CHANGES CREDITS README.md)
+
+python_test() {
+ if [[ ${EPYTHON} == python2* ]]; then
+ # See Bug #644226
+ ewarn "Skipping tests for ${EPYTHON} because they are known to fail"
+ else
+ esetup.py test
+ fi
+}