summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-07-04 19:28:14 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-07-04 19:42:03 +0200
commit4974e9323c4c899bd11d2e2117409b696d6899eb (patch)
tree3f89e3dbda9ff2e2dc3d96763f50b1ce1fe4372b
parentwww-apache/mod_gnutls: enable lfs flags on 0.12.0 (diff)
downloadgentoo-4974e9323c4c899bd11d2e2117409b696d6899eb.tar.gz
gentoo-4974e9323c4c899bd11d2e2117409b696d6899eb.tar.bz2
gentoo-4974e9323c4c899bd11d2e2117409b696d6899eb.zip
www-apps/nextcloud: add 22.2.9, 23.0.6, 24.0.2
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--www-apps/nextcloud/Manifest3
-rw-r--r--www-apps/nextcloud/nextcloud-22.2.9.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-23.0.6.ebuild43
-rw-r--r--www-apps/nextcloud/nextcloud-24.0.2.ebuild43
4 files changed, 132 insertions, 0 deletions
diff --git a/www-apps/nextcloud/Manifest b/www-apps/nextcloud/Manifest
index cacb0ff32100..a4016f2fa171 100644
--- a/www-apps/nextcloud/Manifest
+++ b/www-apps/nextcloud/Manifest
@@ -1,3 +1,6 @@
DIST nextcloud-22.2.8.tar.bz2 131507024 BLAKE2B 3c2a57332d4592f351ab2ef550abe8ae911cf2a1e6a65d8fa7983dd63ef38eb92f9facb37405d28e20244327cf370620db71793178563903bcf438ad059089ef SHA512 4bd3c7cb6c56c737d03e6c297a02dcbcf9b24c0c6c5367088d0067d1a897afadc3f38ed13d2a180ccbbf7dce70a00819ffebfc47dcd27ddc4a628c50c1636d92
+DIST nextcloud-22.2.9.tar.bz2 131366697 BLAKE2B 6ce35d039cf108a41e1dd378d2eaaa4539f5d388c04361479547b323e7a8b55fecbb7bb88fb80d3fa0c8cd7b94a6ddcf73171a9236a0fa7c19b785f7e075dac0 SHA512 5438d6f6e49a620f09f76cd7563c218521093e6d854617319b2b32e49333791a0483fdf03e62f5c75cbd259cffacc27455b37ba59bfaec639e5f5ffaae78a3bf
DIST nextcloud-23.0.5.tar.bz2 140493624 BLAKE2B 13c524a2f26affd3c078210cf1552b1af044fdcd3c6cdcb2a2bde50808bf2953bbb658efa13ebff8806b2e2deb9ff23e36c0cbd7d8bea17329a6fe7e2845f1b8 SHA512 460ddfa994cf1e9423efa8e940dd1beebec17a99bdf78c238384554618b9590405e58c31bf29b011b7fd41cdd21f183053fc9ef6bd245ca9f47d43a19870a0e4
+DIST nextcloud-23.0.6.tar.bz2 140681183 BLAKE2B 05e57c4c725192672a3ed63005f9563b9bbf3978cf1aa0f8c78e8bb0b08ad0b4953c56079900e17dc98ec296420f26c8af740143cee6a3de39a5dc97cf49f9ff SHA512 e7ac52a7a3793bc710de71c4ead7a7477f697c39ea35ee553745a9355271cd6ac838758ef6a5c80ca1202369fb5cc899f78c594ee4e7561c6984719b0670d53b
DIST nextcloud-24.0.1.tar.bz2 123379803 BLAKE2B fc00f22cf1ed9e09da29ed5681f5e1fa5c46df80ba81f26680391effa1f68b9022879b05d1f92402e7c3c3982c755491eeab151880d7532425b3f230a7ab8166 SHA512 29746cd27356ee81c310854b714189a3d1a3817683cc29706af3d76daa70ceeb1201ead92ba3f6ac0de4c6ccdf6a9bbcf646246dd213fbc85638f92e0d73a2d2
+DIST nextcloud-24.0.2.tar.bz2 123445625 BLAKE2B 6d5482d26caa74abf1627c2b260780f0b7a601f9b9edfac94ad1a72b68be7a7b2674cfa54f1342c75d8265849aa3fa4b4e4882d2f5e3bbf7043b7a1511989d60 SHA512 937855549c1060546aa61a95e51485d70145253072f2e1def4da622c33822a31516f820ed82933d9e9ec32748553430bbea42b8840e534d8f6310c9a9d565db0
diff --git a/www-apps/nextcloud/nextcloud-22.2.9.ebuild b/www-apps/nextcloud/nextcloud-22.2.9.ebuild
new file mode 100644
index 000000000000..3c8e3b4c7564
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-22.2.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-23.0.6.ebuild b/www-apps/nextcloud/nextcloud-23.0.6.ebuild
new file mode 100644
index 000000000000..3c8e3b4c7564
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-23.0.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}
diff --git a/www-apps/nextcloud/nextcloud-24.0.2.ebuild b/www-apps/nextcloud/nextcloud-24.0.2.ebuild
new file mode 100644
index 000000000000..3c8e3b4c7564
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-24.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash(+),intl,json(+),mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/php-argon2-en.txt
+
+ webapp_src_install
+}