summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-09 10:10:41 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-09 10:22:57 +0300
commit498a4b535e8b12ceae4b3b8c60f47dc7c14cbe62 (patch)
tree6d89e7b0c6ca1a82845a7de3a776383e9f075018
parentdev-python/pipenv: drop 2022.6.7 (diff)
downloadgentoo-498a4b53.tar.gz
gentoo-498a4b53.tar.bz2
gentoo-498a4b53.zip
dev-python/pylint: add 2.15.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.15.2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index a2d219f8553d..e4780fcda1c4 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1,3 @@
DIST pylint-2.14.5.gh.tar.gz 1275994 BLAKE2B 0d490e81f758cca0ff5c4108090414373c3276b3a51f54df26938e128d82b15ca976cb62d999d8b012ce1fe69b56988a385110be02b1d2a281e39d9f91cdb378 SHA512 8c4d2b17c078c305b081e7dd225a1e744420e01b27f63217f80d61e6bcd0e4f8381c94c504cacd3b8f96cc58c3c53d693fb59277ccbd396ea31f6c72af666042
DIST pylint-2.15.0.gh.tar.gz 1304038 BLAKE2B f22799cca283cd9a2721e264aa125e6df2a4eb9d9fe682a54a2a62adf76171b13de43b5de6fa6b58253bcafefb7f88b43615427a01edf9a0cc4a956266833c4c SHA512 bbcdff2569e53e1fafd94a8d484740470e70b075e52a07baa5ab817a62cc0c5ddfee42087bab172cac441c74899a4f2446efba9b2bd8deafc5a0338df2cd87aa
+DIST pylint-2.15.2.gh.tar.gz 1309122 BLAKE2B 8dd36d770e5fb232378f15bd2a9257aba7b504e747c6d57fc94a4e8bf2b46e1c30a9063f2243cd46f40fbfc9ecd44c2a657f353a36682a71408a49f250a5fd20 SHA512 2c3fa51718cb6722c5166539e5464110a7d51b9c565d181385197395ee75d2f1360553b0c6d0a1acefb500969f8b4aa8d564f4818086d413e7958e834f1a7337
diff --git a/dev-python/pylint/pylint-2.15.2.ebuild b/dev-python/pylint/pylint-2.15.2.ebuild
new file mode 100644
index 000000000000..1306c2d288fb
--- /dev/null
+++ b/dev-python/pylint/pylint-2.15.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://pypi.org/project/pylint/
+ https://github.com/PyCQA/pylint/
+"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/pyproject.toml#L34 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.14[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.12.4[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.2[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.10.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pylint || die
+
+ local EPYTEST_DESELECT=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ 'tests/test_functional.py::test_functional[no_name_in_module]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ tests/config/pylint_config/test_run_pylint_config.py::test_invocation_of_pylint_config
+ )
+ epytest
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}