summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2020-03-10 02:21:20 +0300
committerMike Gilbert <floppym@gentoo.org>2020-03-10 15:49:56 -0400
commit4991275a1e7a5f59d918fcf98421e78e1b8908df (patch)
treed0a81604d1312f264996ba097716f88380fa4af2
parentsys-kernel/dracut: Version bump to 050 (diff)
downloadgentoo-4991275a.tar.gz
gentoo-4991275a.tar.bz2
gentoo-4991275a.zip
sys-kernel/dracut: Update live ebuild
Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-kernel/dracut/dracut-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-kernel/dracut/dracut-9999.ebuild b/sys-kernel/dracut/dracut-9999.ebuild
index 192c96442040..f34a9db579a2 100644
--- a/sys-kernel/dracut/dracut-9999.ebuild
+++ b/sys-kernel/dracut/dracut-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,7 +11,7 @@ if [[ ${PV} == 9999 ]] ; then
else
[[ "${PV}" = *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
- SRC_URI="https://github.com/dracutdevs/dracut/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://www.kernel.org/pub/linux/utils/boot/${PN}/${P}.tar.xz"
fi
DESCRIPTION="Generic initramfs generation tool"
@@ -31,7 +31,7 @@ RDEPEND="
>=sys-apps/kmod-23[tools]
|| (
>=sys-apps/sysvinit-2.87-r3
- sys-apps/openrc[sysv-utils,selinux?]
+ sys-apps/openrc[sysv-utils(-),selinux?]
sys-apps/systemd[sysv-utils]
)
>=sys-apps/util-linux-2.21
@@ -64,6 +64,7 @@ DOCS=( AUTHORS HACKING NEWS README.md README.generic README.kernel README.module
QA_MULTILIB_PATHS="usr/lib/dracut/.*"
PATCHES=(
+ "${FILESDIR}"/050-gentoo-ldconfig-paths.patch
)
src_configure() {
@@ -79,7 +80,7 @@ src_configure() {
echo ./configure "${myconf[@]}"
./configure "${myconf[@]}" || die
- if [[ ${PV} != 9999 ]] ; then
+ if [[ ${PV} != 9999 && ! -f dracut-version.sh ]] ; then
# Source tarball from github doesn't include this file
echo "DRACUT_VERSION=${PV}" > dracut-version.sh || die
fi