summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-02-13 16:14:43 -0500
committerMike Frysinger <vapier@gentoo.org>2016-02-13 16:14:57 -0500
commit49a98eeac0e9fe37782543aa185ced60ab85f80d (patch)
treeb5eea1a6e9a42582b465f233fbe1971cdff018c6
parentx11-misc/slock: Old. (diff)
downloadgentoo-49a98eea.tar.gz
gentoo-49a98eea.tar.bz2
gentoo-49a98eea.zip
dev-libs/boehm-gc: workaround ia64 build failure #574566
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild8
-rw-r--r--dev-libs/boehm-gc/boehm-gc-7.4.2.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild b/dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild
index dcfdef979a83..5f49136fbec3 100644
--- a/dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild
+++ b/dev-libs/boehm-gc/boehm-gc-7.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -32,6 +32,12 @@ src_configure() {
econf "${config[@]}"
}
+src_compile() {
+ # Workaround build errors. #574566
+ use ia64 && emake src/ia64_save_regs_in_stack.lo
+ default
+}
+
src_install() {
default
use static-libs || prune_libtool_files
diff --git a/dev-libs/boehm-gc/boehm-gc-7.4.2.ebuild b/dev-libs/boehm-gc/boehm-gc-7.4.2.ebuild
index 922121afb77f..7a4be804203b 100644
--- a/dev-libs/boehm-gc/boehm-gc-7.4.2.ebuild
+++ b/dev-libs/boehm-gc/boehm-gc-7.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -32,6 +32,12 @@ src_configure() {
econf "${config[@]}"
}
+src_compile() {
+ # Workaround build errors. #574566
+ use ia64 && emake src/ia64_save_regs_in_stack.lo
+ default
+}
+
src_install() {
default
use static-libs || prune_libtool_files