summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 12:11:37 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:56 +0000
commit49c3896ab477023fb039258ee009ccb3f130a4da (patch)
tree7713e9739fcfe95b2b3d38553b984715dd4707fe
parentdev-haskell/transformers: keyword 0.5.6.2 for ~ppc64 (diff)
downloadgentoo-49c3896ab477023fb039258ee009ccb3f130a4da.tar.gz
gentoo-49c3896ab477023fb039258ee009ccb3f130a4da.tar.bz2
gentoo-49c3896ab477023fb039258ee009ccb3f130a4da.zip
dev-haskell/tree-diff: add 0.2.1.1
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/tree-diff/Manifest1
-rw-r--r--dev-haskell/tree-diff/tree-diff-0.2.1.1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/tree-diff/Manifest b/dev-haskell/tree-diff/Manifest
index f091af93eab2..e2dbf088836f 100644
--- a/dev-haskell/tree-diff/Manifest
+++ b/dev-haskell/tree-diff/Manifest
@@ -1 +1,2 @@
DIST tree-diff-0.1.tar.gz 21644 BLAKE2B 0cd1633970216a994100f852b0982d43b6f1d0dc1b0550e759009250e016d271c5358460ef3999267da597b4e58dd28c3094e0ba4f618ba5990e91740eb63881 SHA512 a4ee703e4b6a18055c7749020863a9571af4620dbb7ea05903693c752e10e3ffa4fee8da0dacc0e4bbf92173e34c9070251881597ca1cd9f7c8ed365e840563c
+DIST tree-diff-0.2.1.1.tar.gz 26042 BLAKE2B c136094949b96069996ae2a68c49ca3476f75909138135a138b1c1f07b833413472d2c497418a8bb6c0c17164e78cf180b548c0d4ab5806269e7348aa86467ba SHA512 07bd947b145ebf894a5f830601529517d003bf4b0ffc9581c8204d710ed8d3941f764376add84ab1757c7d3544e984166115f37c1348a32123d99aea816a0686
diff --git a/dev-haskell/tree-diff/tree-diff-0.2.1.1.ebuild b/dev-haskell/tree-diff/tree-diff-0.2.1.1.ebuild
new file mode 100644
index 000000000000..2252cdac16c3
--- /dev/null
+++ b/dev-haskell/tree-diff/tree-diff-0.2.1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Diffing of (expression) trees"
+HOMEPAGE="https://github.com/phadej/tree-diff"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.10:=[profile?] <dev-haskell/ansi-terminal-0.12:=[profile?]
+ >=dev-haskell/ansi-wl-pprint-0.6.8.2:=[profile?] <dev-haskell/ansi-wl-pprint-0.7:=[profile?]
+ >=dev-haskell/bytestring-builder-0.10.8.2.0:=[profile?] <dev-haskell/bytestring-builder-0.11:=[profile?]
+ >=dev-haskell/parsers-0.12.10:=[profile?] <dev-haskell/parsers-0.13:=[profile?]
+ >=dev-haskell/primitive-0.7.1.0:=[profile?] <dev-haskell/primitive-0.8:=[profile?]
+ >=dev-haskell/quickcheck-2.14.2:2=[profile?] <dev-haskell/quickcheck-2.15:2=[profile?]
+ >=dev-haskell/scientific-0.3.6.2:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
+ >=dev-haskell/semialign-1.1:=[profile?] <dev-haskell/semialign-1.3:=[profile?]
+ >=dev-haskell/strict-0.4.0.1:=[profile?] <dev-haskell/strict-0.5:=[profile?]
+ >=dev-haskell/tagged-0.8.6:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/these-1.1.1.1:=[profile?] <dev-haskell/these-1.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.8.0:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/uuid-types-1.0.3:=[profile?] <dev-haskell/uuid-types-1.1:=[profile?]
+ >=dev-haskell/vector-0.12:=[profile?] <dev-haskell/vector-0.13:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ >=dev-haskell/aeson-1.5.6.0:=[profile?] <dev-haskell/aeson-2.1:=[profile?]
+ >=dev-haskell/base-compat-0.10.5:=[profile?] <dev-haskell/base-compat-0.13:=[profile?]
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( dev-haskell/base-compat
+ >=dev-haskell/tasty-golden-2.3.1.1 <dev-haskell/tasty-golden-2.4
+ >=dev-haskell/tasty-quickcheck-0.10.1 <dev-haskell/tasty-quickcheck-0.11
+ >=dev-haskell/trifecta-2 <dev-haskell/trifecta-2.2
+ || ( ( >=dev-haskell/tasty-1.2 <dev-haskell/tasty-1.3 )
+ || ( ( >=dev-haskell/tasty-1.3.1 <dev-haskell/tasty-1.4 )
+ ( >=dev-haskell/tasty-1.4.2 <dev-haskell/tasty-1.5 ) ) ) )
+"