summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2024-02-27 18:28:51 -0500
committerMike Pagano <mpagano@gentoo.org>2024-02-27 18:28:58 -0500
commit49dcd22af440bdc04dd2eb8de9d8729cb80d6731 (patch)
tree4448e2964688ebb29fb77cd2e3fba8306470d811
parentapp-emacs/slime: Stabilize 2.29.1 ALLARCHES, #925643 (diff)
downloadgentoo-49dcd22af440bdc04dd2eb8de9d8729cb80d6731.tar.gz
gentoo-49dcd22af440bdc04dd2eb8de9d8729cb80d6731.tar.bz2
gentoo-49dcd22af440bdc04dd2eb8de9d8729cb80d6731.zip
www-servers/nginx-unit: add 1.32.0
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.32.0.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index 001dece9cb35..9f39c6efb3b8 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1 +1,2 @@
DIST nginx-unit-1.31.1.tar.gz 907165 BLAKE2B 3df7258754761922dceeb66f369faec465bb2f497b692f706c6f22adb21ddf397b2aa2fee758fc89163c30517edf9cb28803193cd53bb9292573a5b21d396dc4 SHA512 28e5f1e88b9e5e21c5094f901227e193137c120e4af3f2950e113d118a301cabb17abf9f0fea8fc8893f36f6e9ae09f86bbf7a323999da34e71e42615937c57c
+DIST nginx-unit-1.32.0.tar.gz 937300 BLAKE2B e603e76ed1d5838eed60675d922bc60a5c6d2bdb34eb98a2198a161c1743efc55c8f4249f4d734d1356089fc14c494d686b043ccedbd5c80b0a1a74d3bb03483 SHA512 52b1c8d6d07db927a4836e854a1372f27230b03ddb09bc8203c4c8433e8391e4bf35d62de3f37e91cde3680d19c183e3f871d5e22fba20343548946b44be466c
diff --git a/www-servers/nginx-unit/nginx-unit-1.32.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.32.0.ebuild
new file mode 100644
index 000000000000..8b4973c6dc33
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.32.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit flag-o-matic python-single-r1 systemd toolchain-funcs
+
+MY_P="unit-${PV}"
+DESCRIPTION="Dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php8-1 php8-2"
+IUSE="${MY_USE} ${MY_USE_PHP} perl ssl"
+REQUIRED_USE="|| ( ${IUSE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php8-1? ( dev-lang/php:8.1[embed] )
+ php8-2? ( dev-lang/php:8.2[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? (
+ dev-lang/ruby:=
+ dev-ruby/rubygems:=
+ )
+ ssl? ( dev-libs/openssl:0= )
+ virtual/libcrypt:0="
+RDEPEND="${DEPEND}
+ acct-user/nginx-unit
+ acct-group/nginx-unit"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply_user
+ sed -i '/^CFLAGS/d' auto/make || die
+ default
+}
+
+src_configure() {
+ local opt=(
+ --control=unix:/run/${PN}.sock
+ --log=/var/log/${PN}
+ --modules=/usr/$(get_libdir)/${PN}
+ --pid=/run/${PN}.pid
+ --prefix=/usr
+ --state=/var/lib/${PN}
+ --user=${PN}
+ --group=${PN}
+ )
+
+ use ssl && opt+=( --openssl )
+ export AR="$(tc-getAR)"
+ export CC="$(tc-getCC)"
+ ./configure ${opt[@]} --ld-opt="${LDFLAGS}" || die "Core configuration failed"
+
+ # Modules require position-independent code
+ append-cflags $(test-flags-CC -fPIC)
+
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+
+ if use perl ; then
+ echo "1"
+ echo "D is ${D}"
+ emake DESTDIR="${D}/" perl-install
+ fi
+
+ rm -rf "${ED}"/usr/var
+
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd-r2" ${PN}
+ newconfd "${FILESDIR}"/nginx-unit.confd nginx-unit
+ systemd_newunit "${FILESDIR}"/${PN}.service ${PN}.service
+}