summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2019-01-18 09:17:40 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-01-21 23:49:48 +0100
commit49e8474d61bf86da68830072204c176293ce9951 (patch)
treeddfbae7440d6d0b70abd6d8c61df7123c29d14b2
parentapp-text/master-pdf-editor: version bump to 5.2.20. (diff)
downloadgentoo-49e8474d.tar.gz
gentoo-49e8474d.tar.bz2
gentoo-49e8474d.zip
dev-python/texttable: bump to 1.6.0.
Package-Manager: Portage[mgorny]-2.3.51.1 Signed-off-by: Joonas Niilola <juippis@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10859 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-python/texttable/Manifest1
-rw-r--r--dev-python/texttable/texttable-1.6.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/texttable/Manifest b/dev-python/texttable/Manifest
index bc9454b33468..54fd43ed547c 100644
--- a/dev-python/texttable/Manifest
+++ b/dev-python/texttable/Manifest
@@ -1,2 +1,3 @@
DIST texttable-0.9.1.tar.gz 11074 BLAKE2B 465738a7b980f2a216d63b268044c1a1b8c0deb986fd398f0ba0ae30ab84020ac6f179b5314a2071592c38443f9cb86387b9ed573342533af9e825000472ebe5 SHA512 7ec37336ef4b253879d0232dcdb4500cad33ecce1067dd7ea26c221dc2c003ee56360bdbd1dd1e00133301c51c67fb2fe9b1703628804a65f2a6ab8a1e830e50
DIST texttable-1.5.0.tar.gz 10640 BLAKE2B 54bc7f1ac1860e2b88de092528134f8ba63b4f31f621a32e64a242b5f2d3132294818cff6bfdb848d4fa002d515069448dd077a95fa70bdf4e9266e162bb9355 SHA512 f4727947a302c8e1bf09ba08d73f79f083304b42f86f2f181a98f44602961e0b280aedd4e38660630671eac17e6eb92403b89c1ae6ea3cdd3cf861c122b904a3
+DIST texttable-1.6.0.tar.gz 10733 BLAKE2B 80a9b8a224ebaa37066df6a3aaccda6237224976076755b8f81a27eb20e3ef1c0811a529a877778b5ea7b1345ad16d510a7f3d9b6a1caadc582f34015faabb4e SHA512 df685004f24b8c1e7aa1bd6a44c658599805f1a0c6999a4a3e95ecf3a68499f515bea9cb5ccd54f5ee2563af15e9fcde2a7e1827934e4a1fc83c9ae2f5e88a52
diff --git a/dev-python/texttable/texttable-1.6.0.ebuild b/dev-python/texttable/texttable-1.6.0.ebuild
new file mode 100644
index 000000000000..feb6ae0d9242
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5..7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for creating simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cjk test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )
+ )
+"
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]
+ cjk? ( dev-python/cjkwrap[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -vv tests.py || die
+}