summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-09-23 13:54:10 +0200
committerMarek Szuba <marecki@gentoo.org>2020-09-23 14:02:28 +0200
commit49ec02e2a9c5581af83dfd9544cbc24ceeec4b67 (patch)
treecb67486f7ac87b2e4e17e264a47b03a42c2e2c34
parentdev-python/zipp: bump to 3.2.0 (diff)
downloadgentoo-49ec02e2a9c5581af83dfd9544cbc24ceeec4b67.tar.gz
gentoo-49ec02e2a9c5581af83dfd9544cbc24ceeec4b67.tar.bz2
gentoo-49ec02e2a9c5581af83dfd9544cbc24ceeec4b67.zip
net-misc/oidc-agent: bump to 3.3.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-misc/oidc-agent/Manifest1
-rw-r--r--net-misc/oidc-agent/files/oidc-agent-3.3.5_makefile-toolchain-vars.patch48
-rw-r--r--net-misc/oidc-agent/oidc-agent-3.3.5.ebuild59
3 files changed, 108 insertions, 0 deletions
diff --git a/net-misc/oidc-agent/Manifest b/net-misc/oidc-agent/Manifest
index cd447dca2a23..2a5395fd9d79 100644
--- a/net-misc/oidc-agent/Manifest
+++ b/net-misc/oidc-agent/Manifest
@@ -1 +1,2 @@
DIST oidc-agent-3.3.1.tar.gz 764721 BLAKE2B eea09b3b140ca81be0f3dc8f200120287682ddb328275be35bd736249b72eabb40c87ebd168e51c992ccd4b4a02138e17d3e20f3cebfb4d42bde01351aacead1 SHA512 75428bb52c0cf43256fddd3b33895d7c882ced367543763c68a385448dbe29805ee1fc035f3727e743a607ed4af851ae5db24b40cc6801fc31e45b6fec16bd66
+DIST oidc-agent-3.3.5.tar.gz 766803 BLAKE2B 4998820283d38e3cee76ab7c308075b74da735f6b2c05ed562c5d61006c5ba85f1c44d7e2c0bfb5e4ee60017835ecf331f8b82a45aa5d0105b7933eeec1025a0 SHA512 c58d9e61a99bf870ce4be0e4fde3faa90b8197d0714626412d162c2e09cca18df734a062b792f7fc92323b50677c64df4aeda5ee42a5ea4e44731ad0e15c8030
diff --git a/net-misc/oidc-agent/files/oidc-agent-3.3.5_makefile-toolchain-vars.patch b/net-misc/oidc-agent/files/oidc-agent-3.3.5_makefile-toolchain-vars.patch
new file mode 100644
index 000000000000..b9d526a2122e
--- /dev/null
+++ b/net-misc/oidc-agent/files/oidc-agent-3.3.5_makefile-toolchain-vars.patch
@@ -0,0 +1,48 @@
+1. Support user-provided values of CC, CFLAGS and LDFLAGS
+2. Do not force the use of a static version of libsodium
+
+--- a/Makefile
++++ b/Makefile
+@@ -54,20 +54,20 @@
+ endif
+
+ # Compiler options
+-CC = gcc
++CC := $(CC)
+ # compiling flags here
+-CFLAGS = -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra -fno-common
++CFLAGS := $(CFLAGS) -g -std=c99 -I$(SRCDIR) -I$(LIBDIR) -Wall -Wextra -fno-common
+ ifndef MAC_OS
+ CFLAGS += $(shell pkg-config --cflags libsecret-1)
+ endif
+ TEST_CFLAGS = $(CFLAGS) -I.
+
+ # Linker options
+-LINKER = gcc
++LINKER := $(CC)
+ ifdef MAC_OS
+ LFLAGS = -lsodium -largp
+ else
+-LFLAGS = -l:libsodium.a -lseccomp -fno-common
++LFLAGS := $(LDFLAGS) -lsodium -lseccomp -fno-common
+ endif
+ ifdef HAS_CJSON
+ LFLAGS += -lcjson
+@@ -81,7 +81,7 @@
+ ifdef MAC_OS
+ CLIENT_LFLAGS = -L$(APILIB) -largp -loidc-agent.$(LIBVERSION)
+ else
+-CLIENT_LFLAGS = -L$(APILIB) -l:$(SHARED_LIB_NAME_FULL) -lseccomp
++CLIENT_LFLAGS = $(LDFLAGS) -L$(APILIB) -l:$(SHARED_LIB_NAME_FULL) -lseccomp
+ endif
+ ifdef HAS_CJSON
+ CLIENT_LFLAGS += -lcjson
+@@ -478,7 +478,7 @@
+ ifdef MAC_OS
+ @gcc -dynamiclib -fpic -Wl, -o $@ $(PIC_OBJECTS) -lc
+ else
+- @gcc -shared -fpic -Wl,-soname,$(SONAME) -o $@ $(PIC_OBJECTS) -lc
++ @$(LINKER) -shared -fpic -Wl,-soname,$(SONAME) $(LDFLAGS) -o $@ $(PIC_OBJECTS) -lc
+ endif
+
+ .PHONY: shared_lib
diff --git a/net-misc/oidc-agent/oidc-agent-3.3.5.ebuild b/net-misc/oidc-agent/oidc-agent-3.3.5.ebuild
new file mode 100644
index 000000000000..8c424ae08feb
--- /dev/null
+++ b/net-misc/oidc-agent/oidc-agent-3.3.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic xdg-utils
+
+DESCRIPTION="oidc-agent for managing OpenID Connect tokens on the command line"
+HOMEPAGE="https://github.com/indigo-dc/oidc-agent"
+SRC_URI="https://github.com/indigo-dc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="app-crypt/libsecret
+ dev-libs/libsodium
+ net-libs/libmicrohttpd
+ sys-libs/libseccomp"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-libs/check )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.1_desktop-category.patch
+ "${FILESDIR}"/${PN}-3.3.1_install-perms.patch
+ "${FILESDIR}"/${PN}-3.3.5_makefile-toolchain-vars.patch
+)
+
+src_compile() {
+ # Parallel building doesn't work
+ emake -j1
+}
+
+src_install() {
+ emake \
+ PREFIX="${ED}" \
+ BIN_AFTER_INST_PATH="/usr" \
+ INCLUDE_PATH="${ED}"/usr/include \
+ LIB_PATH="${ED}"/usr/$(get_libdir) \
+ install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+ elog "You should use oidc-gen to initially generate your account configuration"
+ elog "before it can be loaded into oidc-agent using oidc-add. For details, please"
+ elog "consult the man page of oidc-gen, or full documentation at"
+ elog " https://indigo-dc.gitbooks.io/oidc-agent/"
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}