summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-28 12:42:06 +0000
committerSam James <sam@gentoo.org>2022-06-28 12:42:33 +0000
commit49f695c88dc3c87ae13c4d7525d3cd866661f91d (patch)
treea5bec7429635df5ea67cbf7985fdb4b71fb2ab9d
parentprofiles: Unmask php8-1 PHP_TARGETS USE (diff)
downloadgentoo-49f695c8.tar.gz
gentoo-49f695c8.tar.bz2
gentoo-49f695c8.zip
perl-core/Compress-Raw-Zlib: add 2.202.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.202.0.ebuild31
-rw-r--r--perl-core/Compress-Raw-Zlib/Manifest1
2 files changed, 32 insertions, 0 deletions
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.202.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.202.0.ebuild
new file mode 100644
index 000000000000..c33577df730c
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.202.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PMQS
+DIST_TEST=parallel
+DIST_VERSION=2.202
+inherit perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# We use the bundled version of zlib as the minimum version for the system copy
+# Check on bumps! Look in https://github.com/pmqs/Compress-Raw-Zlib/commits/master/zlib-src.
+RDEPEND=">=sys-libs/zlib-1.2.12"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+src_prepare() {
+ rm -rf "${S}"/zlib-src/ || die
+ sed -i '/^zlib-src/d' "${S}"/MANIFEST || die
+ perl-module_src_prepare
+}
+
+src_configure() {
+ BUILD_ZLIB=False ZLIB_INCLUDE="${ESYSROOT}"/usr/include \
+ ZLIB_LIB="${ESYSROOT}"/usr/$(get_libdir) perl-module_src_configure
+}
diff --git a/perl-core/Compress-Raw-Zlib/Manifest b/perl-core/Compress-Raw-Zlib/Manifest
index 65da62873b24..a85258cf5797 100644
--- a/perl-core/Compress-Raw-Zlib/Manifest
+++ b/perl-core/Compress-Raw-Zlib/Manifest
@@ -1 +1,2 @@
DIST Compress-Raw-Zlib-2.201.tar.gz 480467 BLAKE2B e2c706447cdd82c712b0613da69903adb3e9f51dd3e791bea51c836a767ca1df03f18870d377fea20af5f5ffb074925b0a70c80ef507622264d21b657bda4ea2 SHA512 1262f5be347e1efe71f0308385a5b8b927854b1e061d69d9a38c74e6dfacf2ffbec0891bdeb76092de28a5049e1fd1eb3e784e0570b34612a8256d955d7f1ab7
+DIST Compress-Raw-Zlib-2.202.tar.gz 480563 BLAKE2B 8e9eef5fae7dcac500b08ee7315e6d05912fe954e18560f1ecc195800343102cd0f97690c46c5e06bc6c734877e48356cb93fa70d7070c954e62dc2a7bd2d6c5 SHA512 add25f83ecd83fe3beaad12a6f8b37ca046fdfccfa44c03f32b104a9ec6c132407dc606ba0e30fad67151f1b1d4f6886991b19948c12e2964df13a6daa703e72