summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-12 11:26:07 +0100
committerSam James <sam@gentoo.org>2022-06-12 11:36:25 +0100
commit4a0dcf6b2ab6b2bc5725cc51b813bfa478bee3cf (patch)
treed134720500972aef52237a2c6e01605f1de2e87b
parentmedia-sound/mpdscribble: fix build with GCC 12 (diff)
downloadgentoo-4a0dcf6b2ab6b2bc5725cc51b813bfa478bee3cf.tar.gz
gentoo-4a0dcf6b2ab6b2bc5725cc51b813bfa478bee3cf.tar.bz2
gentoo-4a0dcf6b2ab6b2bc5725cc51b813bfa478bee3cf.zip
sci-chemistry/openbabel: fix build with GCC 12
Closes: https://bugs.gentoo.org/851510 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-chemistry/openbabel/files/openbabel-3.1.1-fix-time-check-cmake.patch32
-rw-r--r--sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild4
2 files changed, 36 insertions, 0 deletions
diff --git a/sci-chemistry/openbabel/files/openbabel-3.1.1-fix-time-check-cmake.patch b/sci-chemistry/openbabel/files/openbabel-3.1.1-fix-time-check-cmake.patch
new file mode 100644
index 000000000000..69e41211023b
--- /dev/null
+++ b/sci-chemistry/openbabel/files/openbabel-3.1.1-fix-time-check-cmake.patch
@@ -0,0 +1,32 @@
+https://github.com/openbabel/openbabel/pull/2493
+
+From: Sam James <sam@gentoo.org>
+Date: Sun, 12 Jun 2022 11:23:59 +0100
+Subject: [PATCH] CMake: fix time check typo (fixes build failure w/ GCC 12)
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Without this fixed check, we get a build failure with GCC 12:
+```
+/var/tmp/portage/sci-chemistry/openbabel-3.1.1_p20210225/work/openbabel-08e23f39b0cc39b4eebd937a5a2ffc1a7bac3e1b/include/openbabel/obutil.h:65:14: error: ‘clock’ was not declared in this scope; did you mean ‘clock_t’?
+ 65 | start= clock();
+ | ^~~~~
+ | clock_t
+```
+
+Bug: https://bugs.gentoo.org/851510
+--- a/src/config.h.cmake
++++ b/src/config.h.cmake
+@@ -182,8 +182,8 @@
+ #define OB_MODULE_PATH "@OB_MODULE_PATH@"
+
+ #ifndef TIME_WITH_SYS_TIME
+- #ifdef HAVE_SYS_TIME
+- #ifdef HAVE_TIME
++ #ifdef HAVE_SYS_TIME_H
++ #ifdef HAVE_TIME_H
+ #define TIME_WITH_SYS_TIME 1
+ #else
+ #define TIME_WITH_SYS_TIME 0
+
diff --git a/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild b/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild
index 61a6ad498b66..0eb8ddaa0cf5 100644
--- a/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild
+++ b/sci-chemistry/openbabel/openbabel-3.1.1_p20210225.ebuild
@@ -80,6 +80,10 @@ RDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/openbabel-3.1.1-fix-time-check-cmake.patch
+)
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}