summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-08-29 01:50:31 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-09-11 23:34:45 +0100
commit4a156ca310556e39707f1fae9de82d7aa68e2eae (patch)
tree460da6f971715fb86bab2e68d098c6c20437d848
parentgames-engines/fheroes2: add 1.0.8 (diff)
downloadgentoo-4a156ca310556e39707f1fae9de82d7aa68e2eae.tar.gz
gentoo-4a156ca310556e39707f1fae9de82d7aa68e2eae.tar.bz2
gentoo-4a156ca310556e39707f1fae9de82d7aa68e2eae.zip
games-engines/fheroes2: drop 1.0.6
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Closes: https://github.com/gentoo/gentoo/pull/32503 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-engines/fheroes2/Manifest1
-rw-r--r--games-engines/fheroes2/fheroes2-1.0.6.ebuild77
2 files changed, 0 insertions, 78 deletions
diff --git a/games-engines/fheroes2/Manifest b/games-engines/fheroes2/Manifest
index 1c86b0a01dd1..7af5d3cb2ddc 100644
--- a/games-engines/fheroes2/Manifest
+++ b/games-engines/fheroes2/Manifest
@@ -1,2 +1 @@
-DIST fheroes2-1.0.6.tar.gz 11611881 BLAKE2B b7219a1a843f4a08cfc9ade161e38b19dcb343fa6dc700568d2e38b984d2cd26c78d02b9792f7d893b0babcca7bf71a01d349bc3806136736d46768b048a8db2 SHA512 c42b2ded44b7d6e112de3e919044b6b7d69161cc8cf08198df88da42c7f77b2dcf9df9ea7b453def66902e85f42047c0375b093c8d2d91517acb42d1804e621b
DIST fheroes2-1.0.8.tar.gz 11757081 BLAKE2B 5448ab4b8379046d632ee8ee1be3207e4b2bd7a7a8f8c2744b2c95b909128d71a1247c8c30a903cc283df7de04e1e5b3a07bac98346b4ec444dff891aa50c028 SHA512 90c198249ecd321c0c69c2e9296364c4d6d566df374198837aa2c7811c21ecf49561342006bd76f948ed14831b22d6b7d36df1c9b46d93c0aeb48052510c588e
diff --git a/games-engines/fheroes2/fheroes2-1.0.6.ebuild b/games-engines/fheroes2/fheroes2-1.0.6.ebuild
deleted file mode 100644
index 0481e2bc397d..000000000000
--- a/games-engines/fheroes2/fheroes2-1.0.6.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake python-single-r1 xdg
-
-DESCRIPTION="Recreation of HoMM2 game engine"
-HOMEPAGE="https://ihhub.github.io/fheroes2/"
-SRC_URI="https://github.com/ihhub/fheroes2/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="tools"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="
- media-libs/libpng:=
- media-libs/libsdl2[video]
- media-libs/sdl2-image
- media-libs/sdl2-mixer
- sys-libs/zlib
-"
-RDEPEND="
- ${DEPEND}
- ${PYTHON_DEPS}
- app-arch/libarchive
- dev-lang/python
- virtual/libintl
-"
-BDEPEND="
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/fheroes2-1.0.4-scripts.patch"
-)
-
-src_configure() {
- # Not using dev-games/libsmacker because the game crashes with it
- local mycmakeargs=(
- -DENABLE_IMAGE=ON
- -DENABLE_TOOLS=$(usex tools)
- -DUSE_SYSTEM_LIBSMACKER=NO
- )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- emake -C files/lang
-}
-
-src_install() {
- cmake_src_install
-
- if use tools; then
- for file in 82m2wav bin2txt extractor h2dmgr icn2img pal2img til2img xmi2midi; do
- newbin "${BUILD_DIR}/${file}" "fheroes2-${file}"
- done
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- elog "You need original HoMM2 data files to play fheroes2."
- elog "If you have an installer (.exe) from GOG, install:"
- elog " games-strategy/homm2-gold-gog"
- elog "If you have the original game installed somewhere already, run:"
- elog " ${EPREFIX}/usr/share/fheroes2/extract_homm2_resources.sh"
- elog "Also you can automatically get a demo version for free by installing:"
- elog " games-strategy/homm2-demo"
-}