summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-11-26 16:56:28 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-11-26 16:56:54 -0600
commit4a1a8d9365a31ef7868d9f774f7e1f224a90e54e (patch)
treefd9f04307d11a556d9590d45b3ecd44c579f93f7
parentmedia-plugins/gst-plugins-ladspa: 1.12.3 bup (diff)
downloadgentoo-4a1a8d93.tar.gz
gentoo-4a1a8d93.tar.bz2
gentoo-4a1a8d93.zip
media-sound/pulseeffects: initial add
Package-Manager: Portage-2.3.14, Repoman-2.3.6
-rw-r--r--media-sound/pulseeffects/Manifest1
-rw-r--r--media-sound/pulseeffects/metadata.xml9
-rw-r--r--media-sound/pulseeffects/pulseeffects-3.0.8.ebuild59
-rw-r--r--media-sound/pulseeffects/pulseeffects-9999.ebuild59
4 files changed, 128 insertions, 0 deletions
diff --git a/media-sound/pulseeffects/Manifest b/media-sound/pulseeffects/Manifest
new file mode 100644
index 000000000000..61ae9377f537
--- /dev/null
+++ b/media-sound/pulseeffects/Manifest
@@ -0,0 +1 @@
+DIST pulseeffects-3.0.8.tar.gz 604530 BLAKE2B e55b08a861f8a9b45191727d000b28b6468d1d46328726ef30f63733bf6b3dd6b745d3f4c38f54c5924950c489c70bb87b57ada4735ce68420d678e93019da65 SHA512 2610b19c0a61510ab9ab29d2fb038a76dcdaf6c168f57d13df8baf32493cf2fe56cfad73f862144117ce511864b405c9d78f294afcab6bc4336ffc234e18110b
diff --git a/media-sound/pulseeffects/metadata.xml b/media-sound/pulseeffects/metadata.xml
new file mode 100644
index 000000000000..72f2c5745fbe
--- /dev/null
+++ b/media-sound/pulseeffects/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jpizarrocallejas@gmail.com</email>
+ <name>Jorge Pizarro Callejas</name>
+ <description>Jorgicio Gentoo Overlay</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-sound/pulseeffects/pulseeffects-3.0.8.ebuild b/media-sound/pulseeffects/pulseeffects-3.0.8.ebuild
new file mode 100644
index 000000000000..82799b6d8fbb
--- /dev/null
+++ b/media-sound/pulseeffects/pulseeffects-3.0.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit gnome2-utils meson python-r1
+
+DESCRIPTION="Limiter, compressor, reverberation, equalizer auto volume effects for Pulseaudio"
+HOMEPAGE="https://github.com/wwmm/pulseeffects"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="${HOMEPAGE}"
+ KEYWORDS=""
+else
+ SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+ python_targets_python3_4? ( dev-python/configparser )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ media-plugins/swh-plugins
+ >=x11-libs/gtk+-3.18:3
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.18[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-1.12.0:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-bad:1.0
+ media-plugins/gst-plugins-ladspa:1.0
+"
+RDEPEND="${DEPEND}
+ media-sound/pulseaudio[equalizer]
+"
+
+pkg_preinst(){
+ gnome2_schemas_savelist
+}
+
+pkg_postinst(){
+ gnome2_gconf_install
+ gnome2_schemas_update
+}
+
+pkg_postrm(){
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+}
diff --git a/media-sound/pulseeffects/pulseeffects-9999.ebuild b/media-sound/pulseeffects/pulseeffects-9999.ebuild
new file mode 100644
index 000000000000..82799b6d8fbb
--- /dev/null
+++ b/media-sound/pulseeffects/pulseeffects-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit gnome2-utils meson python-r1
+
+DESCRIPTION="Limiter, compressor, reverberation, equalizer auto volume effects for Pulseaudio"
+HOMEPAGE="https://github.com/wwmm/pulseeffects"
+
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="${HOMEPAGE}"
+ KEYWORDS=""
+else
+ SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+ python_targets_python3_4? ( dev-python/configparser )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ media-plugins/swh-plugins
+ >=x11-libs/gtk+-3.18:3
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-0.18[${PYTHON_USEDEP}]
+ >=media-libs/gstreamer-1.12.0:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gst-plugins-bad:1.0
+ media-plugins/gst-plugins-ladspa:1.0
+"
+RDEPEND="${DEPEND}
+ media-sound/pulseaudio[equalizer]
+"
+
+pkg_preinst(){
+ gnome2_schemas_savelist
+}
+
+pkg_postinst(){
+ gnome2_gconf_install
+ gnome2_schemas_update
+}
+
+pkg_postrm(){
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+}