summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-08 22:32:35 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-08 22:32:35 +0000
commit4a277e131bea7995017b9f85e13939ab4e6471c9 (patch)
treebafea767f5a2e27eed6702932a12903dad795fc6
parentsys-libs/libunwind: bump up to 1.3.1 (diff)
downloadgentoo-4a277e131bea7995017b9f85e13939ab4e6471c9.tar.gz
gentoo-4a277e131bea7995017b9f85e13939ab4e6471c9.tar.bz2
gentoo-4a277e131bea7995017b9f85e13939ab4e6471c9.zip
sys-libs/libunwind: drop old
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--sys-libs/libunwind/Manifest1
-rw-r--r--sys-libs/libunwind/libunwind-1.1-r1.ebuild72
-rw-r--r--sys-libs/libunwind/libunwind-1.2.1-r2.ebuild105
3 files changed, 0 insertions, 178 deletions
diff --git a/sys-libs/libunwind/Manifest b/sys-libs/libunwind/Manifest
index d92e29959c42..7950dc6ece9e 100644
--- a/sys-libs/libunwind/Manifest
+++ b/sys-libs/libunwind/Manifest
@@ -1,3 +1,2 @@
-DIST libunwind-1.1.tar.gz 1098603 BLAKE2B c1ef0916c45786dcf820bef164f03e27af29f84d3173dc3a2e9fd54486a18d99713df152d810db4eb3e36df4afa7df1b544e6c9271479e2fcbffe473a17c4372 SHA512 bfe04f2bfac9f9e47c37f0b23ed2f264d8d3d3d6f1392fe9d794ee13cad216b3740979e922e4276fb65c1ccdc836fce48812cb5459ecdd2a89a621036a35d7c1
DIST libunwind-1.2.1.tar.gz 780774 BLAKE2B a5be4142e1e4932231023bdec2ab3ecd6b707faf2d32d2b571239252a1d0fb6a273a6a46c4a107db63f74f7b54c0c54cf252b8b79ad53216333ba7bcf63147a1 SHA512 af7c280d2a963779a4a2711887618bc96383011e4e5d52e4085aa7fb351e55e357468f6ff85e66a216f1c6826538f498335a917a5970575c93be74c96316319b
DIST libunwind-1.3.1.tar.gz 801262 BLAKE2B 4dfcd5e170ef0f7626aa966672f3302b4d8f231fcda37c72fbddb9ab913e82b45bb613b22c5ead8bbd5b09fa92bc0db1c32a744b11e40fd736c3a1412ad3d842 SHA512 3110d0aed4f5c781ef1ff72c9337e59793c02c42066209a4ac44f50eff1c0b0e02a5ff9f66891e62016de14af065a47975763970b839b700c0ff2e9f415c8def
diff --git a/sys-libs/libunwind/libunwind-1.1-r1.ebuild b/sys-libs/libunwind/libunwind-1.1-r1.ebuild
deleted file mode 100644
index d6226861dbdd..000000000000
--- a/sys-libs/libunwind/libunwind-1.1-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils libtool
-
-DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
-HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
-SRC_URI="mirror://nongnu/libunwind/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="7"
-KEYWORDS="amd64 arm hppa ia64 ~mips ppc ppc64 -sparc x86 ~amd64-linux ~x86-linux"
-IUSE="debug debug-frame libatomic lzma +static-libs"
-
-RESTRICT="test" #461958 -- re-enable tests with >1.1 again for retesting, this is here for #461394
-
-# We just use the header from libatomic.
-RDEPEND="lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}
- libatomic? ( dev-libs/libatomic_ops )"
-
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
-QA_DT_NEEDED_x86_fbsd="usr/lib/libunwind.so.7.0.0"
-
-src_prepare() {
- # These tests like to fail. bleh.
- echo 'int main(){return 0;}' > tests/Gtest-dyn1.c
- echo 'int main(){return 0;}' > tests/Ltest-dyn1.c
-
- # Since we have tests disabled via RESTRICT, disable building in the subdir
- # entirely. This worksaround some build errors too. #484846
- sed -i -e '/^SUBDIRS/s:tests::' Makefile.in || die
-
- sed -i -e '/LIBLZMA/s:-lzma:-llzma:' configure{.ac,} || die #444050
- epatch "${FILESDIR}"/${P}-lzma.patch #444050
- epatch "${FILESDIR}"/${P}-fix-CVE-2015-3239.patch #585830
- elibtoolize
-}
-
-src_configure() {
- # https://savannah.nongnu.org/bugs/index.php?34324
- # --enable-cxx-exceptions: always enable it, headers provide the interface
- # and on some archs it is disabled by default causing a mismatch between the
- # API and the ABI, bug #418253
- # conservative-checks: validate memory addresses before use; as of 1.0.1,
- # only x86_64 supports this, yet may be useful for debugging, couple it with
- # debug useflag.
- ac_cv_header_atomic_ops_h=$(usex libatomic) \
- econf \
- --enable-cxx-exceptions \
- $(use_enable debug-frame) \
- $(use_enable lzma minidebuginfo) \
- $(use_enable static-libs static) \
- $(use_enable debug conservative_checks) \
- $(use_enable debug)
-}
-
-src_test() {
- # Explicitly allow parallel build of tests.
- # Sandbox causes some tests to freak out.
- SANDBOX_ON=0 emake check
-}
-
-src_install() {
- default
- # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
- # shared library, so we keep it in any case
- use static-libs || find "${ED}"usr '(' -name 'libunwind-generic.a' -o -name 'libunwind*.la' ')' -delete
-}
diff --git a/sys-libs/libunwind/libunwind-1.2.1-r2.ebuild b/sys-libs/libunwind/libunwind-1.2.1-r2.ebuild
deleted file mode 100644
index a64db840b93d..000000000000
--- a/sys-libs/libunwind/libunwind-1.2.1-r2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-${MY_PV}
-inherit autotools eutils libtool multilib-minimal
-
-DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
-HOMEPAGE="https://savannah.nongnu.org/projects/libunwind"
-SRC_URI="mirror://nongnu/libunwind/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="7"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="debug debug-frame doc libatomic lzma +static-libs"
-
-RESTRICT="test" # half of tests are broken (toolchain version dependent)
-
-# We just use the header from libatomic.
-RDEPEND="lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}
- libatomic? ( dev-libs/libatomic_ops )"
-
-S="${WORKDIR}/${MY_P}"
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/libunwind.h
-
- # see libunwind.h for the full list of arch-specific headers
- /usr/include/libunwind-aarch64.h
- /usr/include/libunwind-arm.h
- /usr/include/libunwind-hppa.h
- /usr/include/libunwind-ia64.h
- /usr/include/libunwind-mips.h
- /usr/include/libunwind-ppc32.h
- /usr/include/libunwind-ppc64.h
- /usr/include/libunwind-sh.h
- /usr/include/libunwind-tilegx.h
- /usr/include/libunwind-x86.h
- /usr/include/libunwind-x86_64.h
-)
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.2-coredump-regs.patch #586092
- "${FILESDIR}"/${PN}-1.2-ia64-undwarf.patch
- "${FILESDIR}"/${PN}-1.2-ia64-ptrace-coredump.patch
- "${FILESDIR}"/${PN}-1.2-ia64-missing.patch
- "${FILESDIR}"/${PN}-1.2.1-fix_version_macros.patch
- "${FILESDIR}"/${PN}-1.2.1-only-include-execinfo_h-if-avaliable.patch
- "${FILESDIR}"/${PN}-1.2.1-no-PROTECTED.patch #659732
- "${FILESDIR}"/${PN}-1.2.1-arm-__asm__.patch #635674
-)
-
-src_prepare() {
- default
- chmod +x src/ia64/mk_cursor_i || die
- # Since we have tests disabled via RESTRICT, disable building in the subdir
- # entirely. This worksaround some build errors too. #484846
- sed -i -e '/^SUBDIRS/s:tests::' Makefile.in || die
-
- elibtoolize
- eautoreconf
-}
-
-multilib_src_configure() {
- # --enable-cxx-exceptions: always enable it, headers provide the interface
- # and on some archs it is disabled by default causing a mismatch between the
- # API and the ABI, bug #418253
- # conservative-checks: validate memory addresses before use; as of 1.0.1,
- # only x86_64 supports this, yet may be useful for debugging, couple it with
- # debug useflag.
- ECONF_SOURCE="${S}" \
- ac_cv_header_atomic_ops_h=$(usex libatomic) \
- econf \
- --enable-cxx-exceptions \
- --enable-coredump \
- --enable-ptrace \
- --enable-setjmp \
- $(use_enable debug-frame) \
- $(use_enable doc documentation) \
- $(use_enable lzma minidebuginfo) \
- $(use_enable static-libs static) \
- $(use_enable debug conservative_checks) \
- $(use_enable debug)
-}
-
-multilib_src_compile() {
- # Bug 586208
- CCACHE_NODIRECT=1 default
-}
-
-multilib_src_test() {
- # Explicitly allow parallel build of tests.
- # Sandbox causes some tests to freak out.
- SANDBOX_ON=0 emake check
-}
-
-multilib_src_install() {
- default
- # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
- # shared library, so we keep it in any case
- use static-libs || find "${ED}"usr '(' -name 'libunwind-generic.a' -o -name 'libunwind*.la' ')' -delete
-}