summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-26 19:18:00 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-26 19:18:52 +0300
commit4a506a25b7c6438e9b01ff0da6952c752c515db2 (patch)
tree701e203dbebb8bfa6f4c92d08c86d2aaebcecea8
parentdev-python/pytest-asyncio: add 0.18.3 (diff)
downloadgentoo-4a506a25.tar.gz
gentoo-4a506a25.tar.bz2
gentoo-4a506a25.zip
dev-python/pylint: add 2.13.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.13.1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index 9589e3c0993e..0f2c8b68a381 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1,3 @@
DIST pylint-2.12.2.gh.tar.gz 1032702 BLAKE2B de7dce04159b332baa5c23f4034ee249e49f9239c5c9190213a51a84a47ac2129f8a2265e1ad9c01ab448ec58f4f36653c6de5b0be6bfdf6aa286c8887313759 SHA512 0d2b9b785371af0a1c809271153abbab58f50455b34f12370461ded2c4f3d62656e4c0391adff48e179b95da945a2f44e762863e2b7d63808976bf5f684e20d2
DIST pylint-2.13.0.gh.tar.gz 1114326 BLAKE2B 2d99ae38474a13ecf0b306b2de445b93ef39c4ed286abdbc62e08580b34ea22615983bded024f87eb4ad5e9cfdd12edbab6e7bf841d4e7827c945e798f31771f SHA512 7ca5fdf6d5835886ae01937fad56319cc9b71248d7a8aa6c6d92ba4bf5d35340ec0a16c1b2029d1ca5170f8c3abd29b1d6915a415d5df3c0949f4f9c0d6a690c
+DIST pylint-2.13.1.gh.tar.gz 1116054 BLAKE2B 633636f97e284a8a93c598261b90019ea359fd61cf2e833936749a6a650098772c46008f465b118634cfa3cc8d873d9bbdd7d4b0e54621e47b7c33a33938b01d SHA512 9e5f6f2578d240a4984e00fd9e9a33a39bac4855060054f96c4414d8e1c6c16cd6a27d4d5e82fde52f91b2d25595d638e66e928c82aa3eb72a37c61f7aa6e038
diff --git a/dev-python/pylint/pylint-2.13.1.ebuild b/dev-python/pylint/pylint-2.13.1.ebuild
new file mode 100644
index 000000000000..00f7749a1f55
--- /dev/null
+++ b/dev-python/pylint/pylint-2.13.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="
+ https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint/
+"
+SRC_URI="
+ https://github.com/pycqa/pylint/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~riscv ~x86"
+IUSE="examples"
+
+# Make sure to check https://github.com/PyCQA/pylint/blob/main/setup.cfg#L43 on bumps
+# Adjust dep bounds!
+RDEPEND="
+ <dev-python/astroid-2.12[${PYTHON_USEDEP}]
+ >=dev-python/astroid-2.11.0[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.2[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ <dev-python/isort-6[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ >=dev-python/GitPython-3[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # No need to run the benchmarks
+ tests/benchmark/test_baseline_benchmarks.py
+
+ # TODO
+ 'tests/test_functional.py::test_functional[forgotten_debug_statement_py37]'
+ 'tests/test_functional.py::test_functional[dataclass_with_field]'
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_error_msg
+ tests/checkers/unittest_typecheck.py::TestTypeChecker::test_nomember_on_c_extension_info_msg
+ )
+ # Specify the test directory explicitly to avoid import file mismatches
+ epytest tests
+}
+
+python_install_all() {
+ if use examples ; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}