summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2016-08-24 00:26:57 +0200
committerThomas Deutschmann <whissi@gentoo.org>2016-08-24 02:57:07 +0200
commit4a52463e2acb5535be3fb4b0c8fcc96daff33fd8 (patch)
tree969b418ed0c8a9c4ff1b5df3b397ffc9844885c9
parentnet-misc/tn5250: new revision sans SSLv2/SSLv3 support. (diff)
downloadgentoo-4a52463e.tar.gz
gentoo-4a52463e.tar.bz2
gentoo-4a52463e.zip
dev-libs/libfastjson: Bumped to v0.99.4
Package-Manager: portage-2.3.0
-rw-r--r--dev-libs/libfastjson/Manifest1
-rw-r--r--dev-libs/libfastjson/libfastjson-0.99.4.ebuild41
-rw-r--r--dev-libs/libfastjson/metadata.xml3
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/libfastjson/Manifest b/dev-libs/libfastjson/Manifest
index 2bbace04608e..323619a1dcf0 100644
--- a/dev-libs/libfastjson/Manifest
+++ b/dev-libs/libfastjson/Manifest
@@ -1 +1,2 @@
DIST libfastjson-0.99.2.tar.gz 366602 SHA256 6ff053d455243a81014f37b4d81c746d9b8d40256a56326c3a7921c8bf458dfd SHA512 4b57697cbb901bc12a26d98c3d6df998aba373d4f38339189c9bd3e5a32777fa4796039fe82581337e576fa93c6deb87759eba04326134f587064c82e1b3daaf WHIRLPOOL 56010125b4ba905aba3fa7ad69faf38237426c1ef5cbaad90458fe31e96b86719d2766d2099928dc22aa7d98a64d079a3bd9de31702b28547d1f1d416170d487
+DIST libfastjson-0.99.4.tar.gz 424989 SHA256 6339a67e680a8f6a6a0c179971118489cc14ec73bb1542b591c38f58d760034c SHA512 b38f01469021093f21b43550e7574d2bad7b57a28b62f27cb1d2a57e33d2cb29208d20d978bdebe5a82a9736dfcfd7ec0a0fa945762702f4389d69850c2cfeb3 WHIRLPOOL 15898787b20b13648cfc19496da69e86223400fd9e62cb9ce4362364cf5f6d7df32f54a79e4d225bedcdf91cdb0c9231a3e2a6e63d7366b3290624aaf7854dc7
diff --git a/dev-libs/libfastjson/libfastjson-0.99.4.ebuild b/dev-libs/libfastjson/libfastjson-0.99.4.ebuild
new file mode 100644
index 000000000000..be43af807493
--- /dev/null
+++ b/dev-libs/libfastjson/libfastjson-0.99.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Fork of the json-c library, which is optimized for liblognorm processing"
+HOMEPAGE="http://www.rsyslog.com/tag/libfastjson/"
+SRC_URI="http://download.rsyslog.com/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0/4.0.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE="static-libs"
+
+DEPEND=">=sys-devel/autoconf-archive-2015.02.24"
+RDEPEND=""
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-compile-warnings=yes
+ $(use_enable static-libs static)
+ --disable-rdrand
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog )
+ default
+
+ find "${ED}"usr/lib* -name '*.la' -delete || die
+}
diff --git a/dev-libs/libfastjson/metadata.xml b/dev-libs/libfastjson/metadata.xml
index f380ba05f3f3..11529b22803b 100644
--- a/dev-libs/libfastjson/metadata.xml
+++ b/dev-libs/libfastjson/metadata.xml
@@ -5,6 +5,9 @@
<email>whissi@gentoo.org</email>
<name>Thomas Deutschmann</name>
</maintainer>
+ <slots>
+ <subslots>Reflect ABI of libfastjson.so.</subslots>
+ </slots>
<upstream>
<bugs-to>https://github.com/rsyslog/libfastjson/issues</bugs-to>
<remote-id type="github">rsyslog/libfastjson</remote-id>