summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-15 09:52:21 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-15 10:10:45 +0200
commit4a709fb2f8194cbef2bdedb886e02aaf799843c6 (patch)
tree18b7a147a71828dc72c9adc0bc68b3d7bae5bee0
parentdev-python/cachetools: Bump to 4.1.1 (diff)
downloadgentoo-4a709fb2f8194cbef2bdedb886e02aaf799843c6.tar.gz
gentoo-4a709fb2f8194cbef2bdedb886e02aaf799843c6.tar.bz2
gentoo-4a709fb2f8194cbef2bdedb886e02aaf799843c6.zip
dev-python/flask-security: Bump to 3.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask-security/Manifest1
-rw-r--r--dev-python/flask-security/files/flask-security-3.4.3-optional-deps.patch63
-rw-r--r--dev-python/flask-security/flask-security-3.4.3.ebuild73
3 files changed, 137 insertions, 0 deletions
diff --git a/dev-python/flask-security/Manifest b/dev-python/flask-security/Manifest
index a8eeac2761e7..349f4938ec38 100644
--- a/dev-python/flask-security/Manifest
+++ b/dev-python/flask-security/Manifest
@@ -1 +1,2 @@
DIST Flask-Security-3.0.0.tar.gz 160367 BLAKE2B c2e1449dc2807c2c40519fa3afb894157e17ecc9ff3f6dcf5ef0d02839a5988f827afd26c1d31af86d5e240e0ea8bfb8ed86354bb6a83535436b08721cac8f26 SHA512 09b94f0850372513add5c054c07aa465ecb95e8d1c414647e3ebee571ec08c94a29f0c138d092c02a55e242c422bc53f929ca066d671c082dcb29834ac753984
+DIST flask-security-3.4.3.gh.tar.gz 346540 BLAKE2B ab3b037282bc5b7777ceeaaaf869996f471bc3b954f0b2cf6d17ba44d4014c8c3ac8e34618bc7347bbd1cd6b1c649b49407cb05aad9bd748191c08b7326f679a SHA512 23ad8bc91df418361a556827ff8369777f3716dfd1c97fef6237ba9cb07813eac4033eb3fed80e9ebadeab4f2d2a956b5a652bec80825f939a9fc7d817aa3d90
diff --git a/dev-python/flask-security/files/flask-security-3.4.3-optional-deps.patch b/dev-python/flask-security/files/flask-security-3.4.3-optional-deps.patch
new file mode 100644
index 000000000000..484e816908f4
--- /dev/null
+++ b/dev-python/flask-security/files/flask-security-3.4.3-optional-deps.patch
@@ -0,0 +1,63 @@
+From 8943f49c3e6064839bd1e3c2c73a750b2b476ae3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 15 Jul 2020 09:02:15 +0200
+Subject: [PATCH 1/2] tests: Skip tests requiring specific data backends if not
+ available
+
+Skip tests that require a specific database backend if the respective
+package is not available. This is mostly intended to make it possible
+to test flask-security on Python 3.9 since Pony does not support this
+Python version but there is no harm in extending it to other backends.
+
+Technically, Flask-SQLAlchemy is still required due to other tests.
+---
+ tests/conftest.py | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/tests/conftest.py b/tests/conftest.py
+index 3305d92..a48f480 100644
+--- a/tests/conftest.py
++++ b/tests/conftest.py
+@@ -218,6 +218,7 @@ def mongoengine_datastore(request, app, tmpdir, realdburl):
+
+
+ def mongoengine_setup(request, app, tmpdir, realdburl):
++ pytest.importorskip('flask_mongoengine')
+ from flask_mongoengine import MongoEngine
+ from mongoengine.fields import (
+ BooleanField,
+@@ -282,6 +283,7 @@ def sqlalchemy_datastore(request, app, tmpdir, realdburl):
+
+
+ def sqlalchemy_setup(request, app, tmpdir, realdburl):
++ pytest.importorskip('flask_sqlalchemy')
+ from flask_sqlalchemy import SQLAlchemy
+ from flask_security.models import fsqla_v2 as fsqla
+
+@@ -326,6 +328,7 @@ def sqlalchemy_session_datastore(request, app, tmpdir, realdburl):
+
+
+ def sqlalchemy_session_setup(request, app, tmpdir, realdburl):
++ pytest.importorskip('sqlalchemy')
+ from sqlalchemy import create_engine
+ from sqlalchemy.orm import scoped_session, sessionmaker, relationship, backref
+ from sqlalchemy.ext.declarative import declarative_base
+@@ -426,6 +429,7 @@ def peewee_datastore(request, app, tmpdir, realdburl):
+
+
+ def peewee_setup(request, app, tmpdir, realdburl):
++ pytest.importorskip('peewee')
+ from peewee import (
+ TextField,
+ DateTimeField,
+@@ -522,6 +526,7 @@ def pony_datastore(request, app, tmpdir, realdburl):
+
+ def pony_setup(request, app, tmpdir, realdburl):
+
++ pytest.importorskip('pony')
+ from pony.orm import Database, Optional, Required, Set
+ from pony.orm.core import SetInstance
+
+--
+2.27.0
+
diff --git a/dev-python/flask-security/flask-security-3.4.3.ebuild b/dev-python/flask-security/flask-security-3.4.3.ebuild
new file mode 100644
index 000000000000..3044071d1a63
--- /dev/null
+++ b/dev-python/flask-security/flask-security-3.4.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Simple security for Flask apps"
+HOMEPAGE="
+ https://github.com/Flask-Middleware/flask-security/
+ https://pypi.org/project/Flask-Security-Too/"
+SRC_URI="
+ https://github.com/Flask-Middleware/flask-security/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cachetools[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.14.2[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.7.2[${PYTHON_USEDEP}]
+ >=dev-python/python-email-validator-1.0.5[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
+ >=dev-python/bcrypt-3.1.5[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}]
+ >=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
+ >=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
+ >=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
+ >=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
+ >=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ )"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-optional-deps.patch
+)
+
+src_prepare() {
+ sed -i -e '/setup_requires/d' setup.py || die
+ sed -e 's:--cov flask_security::' \
+ -e 's:--cov-report term-missing::' \
+ -e 's:--black::' \
+ -e 's:--flake8::' \
+ -e 's:--cache-clear::' \
+ -i pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ esetup.py compile_catalog
+}