summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-11 00:39:14 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-11 00:40:08 +0200
commit4a7f27421c511451f5c945f5c8bf952c5e4bf92e (patch)
tree6ca5c70d0c78a3d723e9d81ebc5b0d4cbfd25d24
parent- Update to virtualenvwrapper-4.8.4 incl. EAPI 7 - virtualenvwrapper-4.8.2-r1... (diff)
downloadgentoo-4a7f2742.tar.gz
gentoo-4a7f2742.tar.bz2
gentoo-4a7f2742.zip
net-analyzer/nmap: Version 7.80
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/nmap/Manifest1
-rw-r--r--net-analyzer/nmap/nmap-7.80.ebuild185
2 files changed, 186 insertions, 0 deletions
diff --git a/net-analyzer/nmap/Manifest b/net-analyzer/nmap/Manifest
index 0d32bba7d5fe..753fcf719ae1 100644
--- a/net-analyzer/nmap/Manifest
+++ b/net-analyzer/nmap/Manifest
@@ -1,2 +1,3 @@
DIST nmap-7.70.tar.bz2 10467371 BLAKE2B 53d751773851e45fcfa7604f8b325297f429f525bafdef91e7f693b9a9876ddb23e978c50821776b64764adb5bf36e759042cac3254bdbf36bff7048dfb6f58d SHA512 084c148b022ff6550e269d976d0077f7932a10e2ef218236fe13aa3a70b4eb6506df03329868fc68cb3ce78e4360b200f5a7a491d3145028fed679ef1c9ecae5
+DIST nmap-7.80.tar.bz2 10550327 BLAKE2B 513a5589f4dd72660d290cc03b8130da2c41e4620c5a82e125e4345259b8d0f6efa8bceef47d3c0d2b5b588888b716070e05105a09b0185622aed9268715ae2c SHA512 d4384d3ebf4f3abf3588eed5433f733874ecdceb9342a718dc36db19634b0cc819d73399974eb0a9a9c9dd9e5c88473e07644ec91db28b0c072552b54430be6b
DIST nmap-logo-64.png 3289 BLAKE2B 9563f57d126e6fa38dc777391c2887112836b4f5b521311bde64d5c5a04c45a3f420abba0750f776658015c0018b2afeb381c691bc8784e4f39abc78b9c2d2c7 SHA512 fb102d12aaeebc8a97543ecd653a3606e86996ad679bc26d6e6e274ad05ec3e9f92521289d1a24153c521b699e8c0cfa65d8856bb49af53ee4837268bbc6b5d3
diff --git a/net-analyzer/nmap/nmap-7.80.ebuild b/net-analyzer/nmap/nmap-7.80.ebuild
new file mode 100644
index 000000000000..cf94423c0af1
--- /dev/null
+++ b/net-analyzer/nmap/nmap-7.80.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite,xml"
+inherit autotools desktop flag-o-matic python-single-r1 toolchain-funcs user
+
+MY_P=${P/_beta/BETA}
+
+DESCRIPTION="A utility for network discovery and security auditing"
+HOMEPAGE="https://nmap.org/"
+SRC_URI="
+ https://nmap.org/dist/${MY_P}.tar.bz2
+ https://dev.gentoo.org/~jer/nmap-logo-64.png
+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="
+ ipv6 libressl libssh2 ncat ndiff nls nmap-update nping +nse ssl system-lua
+ zenmap
+"
+NMAP_LINGUAS=( de fr hi hr it ja pl pt_BR ru zh )
+REQUIRED_USE="
+ system-lua? ( nse )
+ ndiff? ( ${PYTHON_REQUIRED_USE} )
+ zenmap? ( ${PYTHON_REQUIRED_USE} )
+"
+RDEPEND="
+ dev-libs/liblinear:=
+ dev-libs/libpcre
+ net-libs/libpcap
+ libssh2? (
+ net-libs/libssh2[zlib]
+ sys-libs/zlib
+ )
+ ndiff? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )
+ nmap-update? (
+ dev-libs/apr
+ dev-vcs/subversion
+ )
+ nse? ( sys-libs/zlib )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ system-lua? ( >=dev-lang/lua-5.2:*[deprecated] )
+ zenmap? (
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.10_beta1-string.patch
+ "${FILESDIR}"/${PN}-5.21-python.patch
+ "${FILESDIR}"/${PN}-6.46-uninstaller.patch
+ "${FILESDIR}"/${PN}-6.25-liblua-ar.patch
+ "${FILESDIR}"/${PN}-7.25-no-FORTIFY_SOURCE.patch
+ "${FILESDIR}"/${PN}-7.25-CXXFLAGS.patch
+ "${FILESDIR}"/${PN}-7.25-libpcre.patch
+ "${FILESDIR}"/${PN}-7.31-libnl.patch
+)
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use ndiff || use zenmap; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ rm -r liblinear/ libpcap/ libpcre/ libssh2/ libz/ || die
+
+ cat "${FILESDIR}"/nls.m4 >> "${S}"/acinclude.m4 || die
+
+ default
+
+ local lingua
+ if use nls; then
+ for lingua in ${NMAP_LINGUAS[@]}; do
+ if ! has ${lingua} ${LINGUAS-${lingua}}; then
+ rm -r zenmap/share/zenmap/locale/${lingua} || die
+ rm zenmap/share/zenmap/locale/${lingua}.po || die
+ fi
+ done
+ else
+ # configure/make ignores --disable-nls
+ for lingua in ${NMAP_LINGUAS[@]}; do
+ rm -r zenmap/share/zenmap/locale/${lingua} || die
+ rm zenmap/share/zenmap/locale/${lingua}.po || die
+ done
+ fi
+
+ sed -i \
+ -e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
+ Makefile.in || die
+ # Fix desktop files wrt bug #432714
+ sed -i \
+ -e 's|^Categories=.*|Categories=Network;System;Security;|g' \
+ zenmap/install_scripts/unix/zenmap-root.desktop \
+ zenmap/install_scripts/unix/zenmap.desktop || die
+
+ sed -i \
+ -e '/AC_CONFIG_SUBDIRS(libz)/d' \
+ -e '/AC_CONFIG_SUBDIRS(libssh2)/d' \
+ configure.ac
+
+ cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
+
+ eautoreconf
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # we need the original for a Darwin-specific fix, bug #604432
+ mv libdnet-stripped/include/config.h.in{.nmap-orig,} || die
+ fi
+}
+
+src_configure() {
+ # The bundled libdnet is incompatible with the version available in the
+ # tree, so we cannot use the system library here.
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with libssh2) \
+ $(use_with ncat) \
+ $(use_with ndiff) \
+ $(use_with nmap-update) \
+ $(use_with nping) \
+ $(use_with ssl openssl) \
+ $(use_with zenmap) \
+ $(usex libssh2 --with-zlib) \
+ $(usex nse --with-zlib) \
+ $(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
+ --cache-file="${S}"/config.cache \
+ --with-libdnet=included \
+ --with-pcre=/usr
+ # Commented out because configure does weird things
+ # --with-liblinear=/usr \
+}
+
+src_compile() {
+ local directory
+ for directory in . libnetutil nsock/src \
+ $(usex ncat ncat '') \
+ $(usex nmap-update nmap-update '') \
+ $(usex nping nping '')
+ do
+ emake -C "${directory}" makefile.dep
+ done
+
+ emake \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB)
+}
+
+src_install() {
+ LC_ALL=C emake -j1 \
+ DESTDIR="${D}" \
+ STRIP=: \
+ nmapdatadir="${EPREFIX}"/usr/share/nmap \
+ install
+ if use nmap-update;then
+ LC_ALL=C emake -j1 \
+ -C nmap-update \
+ DESTDIR="${D}" \
+ STRIP=: \
+ nmapdatadir="${EPREFIX}"/usr/share/nmap \
+ install
+ fi
+
+ dodoc CHANGELOG HACKING docs/README docs/*.txt
+
+ if use zenmap; then
+ doicon "${DISTDIR}/nmap-logo-64.png"
+ python_optimize
+ fi
+}