summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-01 09:07:31 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-01 09:56:07 +0200
commit4a96faead6ff770483fca9edb8f79a8e27541bc7 (patch)
tree955a2003fd814eb3410ad3848c1403742c35c7db
parentxfce-base/libxfce4util: Bump to 4.13.4 (diff)
downloadgentoo-4a96faea.tar.gz
gentoo-4a96faea.tar.bz2
gentoo-4a96faea.zip
xfce-base/xfce4-settings: Bump to 4.13.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/xfce4-settings/Manifest1
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.13.7.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
index 6ea2fa731528..34356599636c 100644
--- a/xfce-base/xfce4-settings/Manifest
+++ b/xfce-base/xfce4-settings/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-settings-4.12.4.tar.bz2 1036773 BLAKE2B 512547a172081d75e7eeb97f499e77320a3df1090e80ef548dbbaf84d454b614ddb6a36bbfe4cd06d18b478ada7bd76f385dde374a93380f848ffcc232b133d3 SHA512 9b74daa3f98f15c8cb696dc79f9913fecb37f2ca44c2fd3f24865ae03e9a1db93cb5a8ddb27da3c4af7d7a9e9d718a22e46188ff515caf925a5cedfaab37b189
DIST xfce4-settings-4.13.6.tar.bz2 1163147 BLAKE2B 28986789cb82f91dd70d33203503cf49c4e20b548722be3cb8a2214ea16b762841cd56ad0ff7fc106b8ee35c812a7b455076c8fdce79aa7bf84e7706c15bd3ab SHA512 7fe4655a5644dec8688eebc508e23bace7af76c6b8eeb3821fa9a4ec79862cde64cf59ee2ac70a27ff378ef887ce6d109ef1b1d9e5f7e98f96fdb43604e024b6
+DIST xfce4-settings-4.13.7.tar.bz2 1177376 BLAKE2B 3d87347f46e5dcc9ab475a48b6a8c3c953948411f736e57172b200ac8548ebb2ec48b3142f3f37d932ace6c0106c2a2e94e5bfa6f194872ac4fe9060364b8844 SHA512 5fdabb05ba9a5fac7f093bee70f56d0c58f225c649d92071618bdd4c7a5443bc9ee9289878397d7223954a4b3e2533d7ff41b42bb85b5fdb7a69d7bbeb39958d
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.13.7.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.13.7.ebuild
new file mode 100644
index 000000000000..35cda5e6ac50
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.13.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="colord input_devices_libinput libcanberra libnotify upower +xklavier"
+
+RDEPEND="
+ >=dev-libs/glib-2.24
+ media-libs/fontconfig
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2
+ >=xfce-base/exo-0.11
+ >=xfce-base/libxfce4ui-4.12
+ >=xfce-base/libxfce4util-4.12
+ >=xfce-base/xfconf-4.13
+ colord? ( x11-misc/colord:= )
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ input_devices_libinput? ( x11-drivers/xf86-input-libinput )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ upower? ( >=sys-power/upower-0.9.23 )
+ xklavier? ( >=x11-libs/libxklavier-5 )"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ x11-base/xorg-proto"
+
+src_configure() {
+ local myconf=(
+ $(use_enable upower upower-glib)
+ $(use_enable input_devices_libinput xorg-libinput)
+ $(use_enable libnotify)
+ $(use_enable colord)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}