summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-02-07 16:01:55 +0200
committerMart Raudsepp <leio@gentoo.org>2019-02-07 16:01:55 +0200
commit4aa01256cf6909ae8a6800d75a8bfcb4ac054dd6 (patch)
tree29d77736f79a19858ddd815b0ccb87c04170bca3
parentprofiles/arch/arm64: Only stable-mask USE=tracker (diff)
downloadgentoo-4aa01256.tar.gz
gentoo-4aa01256.tar.bz2
gentoo-4aa01256.zip
Revert "app-text/docbook-dsssl-stylesheets: Drop old"
This reverts commit 84539a884ace5f12f8e6ba1bd75cd55e6c4bb787. Broke the tree from premature removal of old with arm and more not finished stabilizing newer. Bug: https://bugs.gentoo.org/676434 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r2.ebuild b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r2.ebuild
new file mode 100644
index 000000000000..215efe89a67f
--- /dev/null
+++ b/app-text/docbook-dsssl-stylesheets/docbook-dsssl-stylesheets-1.79-r2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit sgml-catalog
+
+MY_P=${P/-stylesheets/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="DSSSL Stylesheets for DocBook"
+HOMEPAGE="https://github.com/docbook/wiki/wiki"
+SRC_URI="mirror://sourceforge/docbook/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE=""
+
+RDEPEND="app-text/sgml-common"
+
+sgml-catalog_cat_include "/etc/sgml/dsssl-docbook-stylesheets.cat" \
+ "/usr/share/sgml/docbook/dsssl-stylesheets-${PV}/catalog"
+sgml-catalog_cat_include "/etc/sgml/sgml-docbook.cat" \
+ "/etc/sgml/dsssl-docbook-stylesheets.cat"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp "${FILESDIR}/${PN}-1.77.Makefile" Makefile
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ make \
+ BINDIR="${ED}/usr/bin" \
+ DESTDIR="${ED}/usr/share/sgml/docbook/dsssl-stylesheets-${PV}" \
+ install || die
+
+ dodir /usr/share/sgml/stylesheets/dsssl/
+
+ if [ -d "${EPREFIX}"/usr/share/sgml/stylesheets/dsssl/docbook ] &&
+ [ ! -L "${EPREFIX}"/usr/share/sgml/stylesheets/dsssl/docbook ]
+ then
+ ewarn "Not linking /usr/share/sgml/stylesheets/dsssl/docbook to"
+ ewarn "/usr/share/sgml/docbook/dsssl-stylesheets-${PV}"
+ ewarn "as directory already exists there. Will assume you know"
+ ewarn "what you're doing."
+ else
+ dosym ../../docbook/dsssl-stylesheets-${PV} \
+ /usr/share/sgml/stylesheets/dsssl/docbook
+ fi
+
+ dodoc BUGS ChangeLog README RELEASE-NOTES.txt WhatsNew
+}