summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-04 19:49:22 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-04 20:06:34 +0200
commit4ab0b6465b03550fd5501ab37849f979e1a55a01 (patch)
treeedaaf65cd52318b0c0b5aaf2bfa9031a047280a6
parentdev-python/Faker: add 15.2.0 (diff)
downloadgentoo-4ab0b646.tar.gz
gentoo-4ab0b646.tar.bz2
gentoo-4ab0b646.zip
dev-python/weasyprint: add 57.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-57.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 0b0e82863b75..ec108d77fe9d 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -2,3 +2,4 @@ DIST weasyprint-55.0.tar.gz 410970 BLAKE2B ba77f249c3568031eff9b7110864b69113f71
DIST weasyprint-56.0.tar.gz 419236 BLAKE2B c64d382e4ac169904a51fec17152faacccf4ccdab775a3b34b0db7e0a4306e6cadf6810482cee5535991400455864749cce1fc6ba5e0b469a3eb934d62298028 SHA512 d8efc83f77967a514d26806a9b73ef03e047431c6db9b367cd23a819b4a68714d216081afc74162b60084d0f3755498dc782d0335069bc9e70c42b611b737eec
DIST weasyprint-56.1.tar.gz 420035 BLAKE2B ac6ff4fae70406c125f8e5c959acba297fa92644dd6a69a95af0192260c6fc8890b1ae790c25eb16f79a3f527a88e4912787c8d29f4ea213c2fc4ecab589ecf8 SHA512 c64bcef9789cb8c52853cfe02f5249240b67fa8368f3467c0e56cefe8ee9fde3dc9a1a489278e7238ed7fddfebba2f238f37245a3ef4d7482a32cee14dbf66b0
DIST weasyprint-57.0.tar.gz 428504 BLAKE2B f5a1ffd1e5ceed3ec51c5babad38bdcbce34b8183f6226519e82e86b080bae01c106109348233875ec3448b7014765eeb1b07c2eb430c4d49a1e784e60d89262 SHA512 627769b0584804c34aacf52c3006b11d2be50cd79f8f2621ac39a630a9b2dd132dc4e6005c844ced84479f901e24515615755fa1b863825b4bb0edde97b24a7d
+DIST weasyprint-57.1.tar.gz 429652 BLAKE2B c94cc05f6c3b831d3214d7476e3fa799ff62d8fb575044a6f11172e650a87b1277e21fef40577bb01a1a778982a98e1a57801de708b3a3a26520b50aae8b43ac SHA512 0a130fba07d1d73eb4e9dcda27ab51ede45c440717f6fedb8d6aac09283244c366d36d85c2dac85995fbaebac21cf880a0cb684baaff3788af3eb6b4931c014b
diff --git a/dev-python/weasyprint/weasyprint-57.1.ebuild b/dev-python/weasyprint/weasyprint-57.1.ebuild
new file mode 100644
index 000000000000..91e490bc0ec2
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-57.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ || (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ <app-text/ghostscript-gpl-9.56.0
+ )
+ media-fonts/ahem
+ media-fonts/dejavu
+ )
+"
+
+distutils_enable_tests pytest