summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 12:44:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 12:51:07 +0100
commit4aba3cb3d5c20d7002286c8a8839d31d0b20296c (patch)
tree513110dde8faea1e83015361eb5b576e011d3ef7
parentdev-python/ansi: Switch to PEP 517 build (diff)
downloadgentoo-4aba3cb3.tar.gz
gentoo-4aba3cb3.tar.bz2
gentoo-4aba3cb3.zip
dev-python/autoprop: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/autoprop/autoprop-4.0.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/autoprop/autoprop-4.0.2-r1.ebuild b/dev-python/autoprop/autoprop-4.0.2-r1.ebuild
new file mode 100644
index 000000000000..aaa4275f756a
--- /dev/null
+++ b/dev-python/autoprop/autoprop-4.0.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Infer properties from accessor methods"
+HOMEPAGE="
+ https://github.com/kalekundert/autoprop/
+ https://pypi.org/project/autoprop/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/signature_dispatch-1.0.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest