summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-02-20 14:39:07 +0100
committerPacho Ramos <pacho@gentoo.org>2016-02-20 14:53:12 +0100
commit4ae2c13221897e3c09fd319f7397daa2b3afc872 (patch)
tree24f69dc597903ab78fa1403f92cb5c1e1aa57938
parentgnome-extra/libgsf: Drop old (diff)
downloadgentoo-4ae2c13221897e3c09fd319f7397daa2b3afc872.tar.gz
gentoo-4ae2c13221897e3c09fd319f7397daa2b3afc872.tar.bz2
gentoo-4ae2c13221897e3c09fd319f7397daa2b3afc872.zip
gnome-extra/libgsf: Version bump, fix gdk pixbuf dependencies (#570854 by Marinus Schraal)
Package-Manager: portage-2.2.27
-rw-r--r--gnome-extra/libgsf/Manifest1
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.36.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index c041bed6b40c..d65501e5f339 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1 +1,2 @@
DIST libgsf-1.14.34.tar.xz 609880 SHA256 f0fea447e0374a73df45b498fd1701393f8e6acb39746119f8a292fb4a0cb528 SHA512 9a9fbb178147ed80572a8e727b1d3ba1f305c12c6a3b151016daf7eb51b7bf75b30d3397070ce98d6e83acf9617b15eb281fa976df291ab894119d2647826532 WHIRLPOOL c998d25adf0898b65219a9fe78075f8123a448e079fb167acc61b3cbe9093dcb2d9867a48d9d544b3a7b838a41559a3eac1b88e204294d56e49191f3d16f8e48
+DIST libgsf-1.14.36.tar.xz 609764 SHA256 71b7507f86c0f7c341bb362bdc7925a2ae286729be0bf5b8fd9581ffbbd62940 SHA512 ca0345fa4190df4d392e7cf71187d2f3b0c4bbe2312f18c076f1a9fa90e7803a754cec9a7df3da9cd00ded800eb4ad78e7acb099350dcf44c35181cddade7a85 WHIRLPOOL e99ea9a087aad127c469d353c3632d75e98a12045c8e198bb02280991ad6970b0198654ab525dd067e038caba75e710a2203868463900aa409bae332c797b8d2
diff --git a/gnome-extra/libgsf/libgsf-1.14.36.ebuild b/gnome-extra/libgsf/libgsf-1.14.36.ebuild
new file mode 100644
index 000000000000..79bee5c34987
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.36.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}