summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-24 08:35:11 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-24 09:07:01 +0200
commit4afcf436b076dceaa4b2cec1d8c4f588ac542f02 (patch)
tree0e6898f369f8ab5d623ee860ea2a4a19069554cb
parentdev-python/flask-babel: Port to py3.9 (diff)
downloadgentoo-4afcf436b076dceaa4b2cec1d8c4f588ac542f02.tar.gz
gentoo-4afcf436b076dceaa4b2cec1d8c4f588ac542f02.tar.bz2
gentoo-4afcf436b076dceaa4b2cec1d8c4f588ac542f02.zip
dev-python/wtforms: Port to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wtforms/wtforms-2.2.1.ebuild17
1 files changed, 3 insertions, 14 deletions
diff --git a/dev-python/wtforms/wtforms-2.2.1.ebuild b/dev-python/wtforms/wtforms-2.2.1.ebuild
index aeb0c540d6e9..e52ad989976d 100644
--- a/dev-python/wtforms/wtforms-2.2.1.ebuild
+++ b/dev-python/wtforms/wtforms-2.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( pypy3 python2_7 python3_{6..9} )
inherit distutils-r1
MY_PN="WTForms"
@@ -22,8 +22,6 @@ RESTRICT="!test? ( test )"
S="${WORKDIR}/${MY_P}"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
test? (
dev-python/Babel[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
@@ -32,6 +30,8 @@ BDEPEND="
)
"
+distutils_enable_sphinx docs
+
python_prepare_all() {
# Extension-tests are written for an older version of Django
# Disable pep8 even when it is installed
@@ -43,17 +43,6 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
python_test() {
"${EPYTHON}" tests/runtests.py -v || die
}
-
-python_install_all() {
- distutils-r1_python_install_all
-}