summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-28 21:12:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-28 22:43:58 +0200
commit4b01e4b2bb97a215a5a21d1fc8e35bd5806d1ce3 (patch)
tree6899996a2a4a1bd257df405844e47096ada6bb0b
parentvirtual/dist-kernel: Bump to 5.11.17 (diff)
downloadgentoo-4b01e4b2.tar.gz
gentoo-4b01e4b2.tar.bz2
gentoo-4b01e4b2.zip
dev-util/debugedit: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-util/debugedit/Manifest1
-rw-r--r--dev-util/debugedit/debugedit-4.16.1.2.ebuild91
2 files changed, 0 insertions, 92 deletions
diff --git a/dev-util/debugedit/Manifest b/dev-util/debugedit/Manifest
index ecbd826eca9e..230ca396760b 100644
--- a/dev-util/debugedit/Manifest
+++ b/dev-util/debugedit/Manifest
@@ -1,2 +1 @@
-DIST rpm-4.16.1.2.tar.bz2 4346745 BLAKE2B 17485b1e73b30586acb8e9be53bfb0bd430fa05e826755729c68367c798e8cad039f091731b6effbe9fa9b7d6c4018abd6feec94f032230cbbd6068e9080573a SHA512 066b67838312f9ad076285fe8f43527aded694f5562ead4e90df48675f2e99c1f2d68693fd20b2037e2614b978ed94c417753e2dbd055a9869b45264cd932afc
DIST rpm-4.16.1.3.tar.bz2 4354652 BLAKE2B 10013014bdeaf908b64c90f8e76f1d4b0cd0e8cb926f0cd979d7b1e1963b9a25c5b98531deea7e74e00168e2e6349f443fa4578c69c717ca1ab5e6b79d801f3a SHA512 54e503b32dffaa73d6168f26a00220d9d9124082d8a1eb1ddf34ce32a482f07cb06ec654cf065fca1607cc37b13fa7d4fa9895553541d7cfddecf68c9eb96f2e
diff --git a/dev-util/debugedit/debugedit-4.16.1.2.ebuild b/dev-util/debugedit/debugedit-4.16.1.2.ebuild
deleted file mode 100644
index 17d121e9642e..000000000000
--- a/dev-util/debugedit/debugedit-4.16.1.2.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic
-
-MY_P=rpm-${PV}
-DESCRIPTION="Stand-alone debugedit from RPM"
-HOMEPAGE="https://rpm.org
- https://github.com/rpm-software-management/rpm"
-SRC_URI="http://ftp.rpm.org/releases/rpm-$(ver_cut 1-2).x/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2+ LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RDEPEND="
- sys-libs/zlib:=
- >=dev-libs/popt-1.7
- >=dev-libs/elfutils-0.176-r1
- dev-libs/nss
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- eapply_user
-
- # cheat it into believing we're bundling db
- mkdir -p db/dist || die
- touch db/dist/configure || die
- chmod +x db/dist/configure || die
- echo 'install:' > db3/Makefile || die
-
- # TODO: why do we need to do this?
- mkdir rpm || die
- find -name '*.h' -exec cp {} rpm/ ';' || die
-}
-
-src_configure() {
- append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
- local myconf=(
- # force linking to static librpmio
- --disable-shared
-
- # disable linking compression libraries
- ac_cv_header_bzlib_h=no
- ac_cv_header_lzma_h=no
- --disable-zstd
-
- # fake some libraries we don't use
- ac_cv_header_magic_h=yes
- ac_cv_lib_magic_magic_open=yes
-
- # use nss as crypto provider
- --with-crypto=nss
-
- # disable other stuff irrelevant to debugedit
- --disable-bdb
- --disable-nls
- --disable-plugins
- --disable-python
- --without-acl
- --without-archive
- --without-cap
- --without-external-db
- --without-hackingdocs
- --without-lua
- --without-selinux
- )
- econf "${myconf[@]}"
-}
-
-src_compile() {
- emake -C misc
- emake -C rpmio
- emake debugedit
-}
-
-src_test() {
- :
-}
-
-src_install() {
- dobin debugedit
-}