summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-11-23 23:08:25 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-11-23 23:08:25 +0100
commit4b080f78c6e503fb08750c7db7487345a8404159 (patch)
tree88808fc9d413e2c2d62b8431d6c953a3e8a751f6
parentgnustep-base/gnustep-gui: add 0.30.0 (diff)
downloadgentoo-4b080f78c6e503fb08750c7db7487345a8404159.tar.gz
gentoo-4b080f78c6e503fb08750c7db7487345a8404159.tar.bz2
gentoo-4b080f78c6e503fb08750c7db7487345a8404159.zip
x11-misc/grsync: fix compilation with USE=-gtk3
Closes: https://bugs.gentoo.org/916673 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-misc/grsync/grsync-1.3.1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/x11-misc/grsync/grsync-1.3.1.ebuild b/x11-misc/grsync/grsync-1.3.1.ebuild
index b54007c5ee03..20da83187937 100644
--- a/x11-misc/grsync/grsync-1.3.1.ebuild
+++ b/x11-misc/grsync/grsync-1.3.1.ebuild
@@ -23,6 +23,15 @@ BDEPEND="virtual/pkgconfig
DOCS="AUTHORS NEWS README"
+src_prepare() {
+ default
+
+ if ! use gtk3; then
+ sed -e "s/gtk_widget_override_font/gtk_widget_modify_font/" \
+ -i src/callbacks.c || die
+ fi
+}
+
src_configure() {
econf --disable-unity $(use_enable gtk3)
}