summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-10-09 11:44:48 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2019-10-09 11:45:04 +0200
commit4b12c4fd197d1bc58e039bf998355035cc374e93 (patch)
treef39111e27d39ddc0c5ab9508c34e4b9ed001d862
parentwww-apps/piwigo: drop old (diff)
downloadgentoo-4b12c4fd197d1bc58e039bf998355035cc374e93.tar.gz
gentoo-4b12c4fd197d1bc58e039bf998355035cc374e93.tar.bz2
gentoo-4b12c4fd197d1bc58e039bf998355035cc374e93.zip
net-libs/librsync: 2.1.0 bump
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-libs/librsync/Manifest1
-rw-r--r--net-libs/librsync/librsync-2.1.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/librsync/Manifest b/net-libs/librsync/Manifest
index a519a0776321..a9faaa2eba81 100644
--- a/net-libs/librsync/Manifest
+++ b/net-libs/librsync/Manifest
@@ -1,3 +1,4 @@
DIST librsync-0.9.7.tar.gz 453802 BLAKE2B 0f8a7a758d847498876401aa04473946970be0257dc0cc4abce85adc7adb5d480d7a41e03d43f667e44ec646ce74a75dfa6b0c63c7f239338244b67eb432e31f SHA512 339362fd01c94411849d3e4a6e95db1bef6cffa0475b1af49d73f11be0421a12d4c73ecbf1a272af01b2a21cec81b4a801c1f7d735e107d0242707fb4c45f9ef
DIST librsync-2.0.1.tar.gz 169765 BLAKE2B 3b3a109307dc03e567338709f1c3958a2ae7887165208848359677305f6a983edc1bc71c721dd3f414f77e0507426ae5bb59b9fde51595a92379227ac316127a SHA512 70c1ed0f3a8ad8c1201ce67b5411c4aabb4c78ba9d60e4ee658d9a8818c6511322abd53b583869b8927a29b0f105e1a5c9b05efa748eb435e8fc3b7be3344e04
DIST librsync-2.0.2.tar.gz 174480 BLAKE2B e77d554ad08a852459fe2798249f47ca7f26849b4b8622c5b64f7f9b6d23f1fedc443f747c7988679a3548ea1f6fd2902c424717faaf73a5cfd7e19012a2d72d SHA512 5d2bc1d62b37e9ed7416203615d0a0e3c05c4c884b5da63eda10dd5c985845b500331bce226e4d45676729382c85b41528282e25d491afda31ba434ac0fefad7
+DIST librsync-2.1.0.tar.gz 175630 BLAKE2B effd2a8c79fae202921220db7581be1d9f7d278e6ee5155a23e586d9d4a7a27bbc4a50049ddca3b187a8e08451c6dcde7340d22be9fde0c2c12462392043fd8e SHA512 9b91f4b696c1d1cdacb5c0679c7df7a92641e0a6a599c2e5de2bc0af3052b2045bb16c40b072c40859074d792c78c57afb0817917fa9843b179befa4506ebf04
diff --git a/net-libs/librsync/librsync-2.1.0.ebuild b/net-libs/librsync/librsync-2.1.0.ebuild
new file mode 100644
index 000000000000..19f0d6f4bb2c
--- /dev/null
+++ b/net-libs/librsync/librsync-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Remote delta-compression library"
+HOMEPAGE="https://librsync.github.io/"
+SRC_URI="https://github.com/librsync/librsync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="
+ dev-libs/popt
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_LIBB2=OFF
+ )
+
+ cmake-utils_src_configure
+}