summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-10-07 08:47:48 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-10-07 08:48:14 -0700
commit4b2775ec461086a7299d277193f485947d78f817 (patch)
tree5db483dcb7f512c2f8b14f9040b57eb708066555
parentsys-libs/zlib: fix install with slibtool (diff)
downloadgentoo-4b2775ec.tar.gz
gentoo-4b2775ec.tar.bz2
gentoo-4b2775ec.zip
dev-lang/rust: silence rmeta QA WX warnings
Closes: https://bugs.gentoo.org/806466 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-lang/rust/rust-1.52.1.ebuild6
-rw-r--r--dev-lang/rust/rust-1.53.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.54.0.ebuild6
-rw-r--r--dev-lang/rust/rust-1.55.0.ebuild6
4 files changed, 24 insertions, 0 deletions
diff --git a/dev-lang/rust/rust-1.52.1.ebuild b/dev-lang/rust/rust-1.52.1.ebuild
index 903660103f67..30db42404e6a 100644
--- a/dev-lang/rust/rust-1.52.1.ebuild
+++ b/dev-lang/rust/rust-1.52.1.ebuild
@@ -138,6 +138,12 @@ QA_SONAME="
usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/lib.*.so
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
+QA_EXECSTACK="${QA_WX_LOAD}"
+
# causes double bootstrap
RESTRICT="test"
diff --git a/dev-lang/rust/rust-1.53.0.ebuild b/dev-lang/rust/rust-1.53.0.ebuild
index b484a09020c7..aeb7bd1f11c8 100644
--- a/dev-lang/rust/rust-1.53.0.ebuild
+++ b/dev-lang/rust/rust-1.53.0.ebuild
@@ -140,6 +140,12 @@ QA_SONAME="
usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/lib.*.so
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
+QA_EXECSTACK="${QA_WX_LOAD}"
+
# causes double bootstrap
RESTRICT="test"
diff --git a/dev-lang/rust/rust-1.54.0.ebuild b/dev-lang/rust/rust-1.54.0.ebuild
index 40f81de58ea5..0b2c51587d67 100644
--- a/dev-lang/rust/rust-1.54.0.ebuild
+++ b/dev-lang/rust/rust-1.54.0.ebuild
@@ -140,6 +140,12 @@ QA_SONAME="
usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/lib.*.so
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
+QA_EXECSTACK="${QA_WX_LOAD}"
+
# causes double bootstrap
RESTRICT="test"
diff --git a/dev-lang/rust/rust-1.55.0.ebuild b/dev-lang/rust/rust-1.55.0.ebuild
index 0805c94c1d0f..366d1e5149b8 100644
--- a/dev-lang/rust/rust-1.55.0.ebuild
+++ b/dev-lang/rust/rust-1.55.0.ebuild
@@ -140,6 +140,12 @@ QA_SONAME="
usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/lib.*.so
"
+# An rmeta file is custom binary format that contains the metadata for the crate.
+# rmeta files do not support linking, since they do not contain compiled object files.
+# so we can safely silence the warning for this QA check.
+QA_WX_LOAD="usr/lib/${PN}/${PV}/lib/rustlib/.*/lib/.*:lib.rmeta"
+QA_EXECSTACK="${QA_WX_LOAD}"
+
# causes double bootstrap
RESTRICT="test"