summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-10-12 20:36:17 +0200
committerSam James <sam@gentoo.org>2022-10-12 23:34:34 +0100
commit4b27a5ee41d32045907820e303391c6b7bebc3af (patch)
tree2d79e45783e368b2cda08ccdf48e81ed30da118a
parentapp-admin/puppetserver: add 7.9.2 (diff)
downloadgentoo-4b27a5ee.tar.gz
gentoo-4b27a5ee.tar.bz2
gentoo-4b27a5ee.zip
dev-util/muon: add 0.1.0
Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Closes: https://github.com/gentoo/gentoo/pull/27757 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/muon/Manifest2
-rw-r--r--dev-util/muon/muon-0.1.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/muon/Manifest b/dev-util/muon/Manifest
index 00348381fe3b..c48e26ae541c 100644
--- a/dev-util/muon/Manifest
+++ b/dev-util/muon/Manifest
@@ -1,2 +1,4 @@
+DIST meson-docs-0.63.0-239-g41a05ff93.tar.gz 78127 BLAKE2B ec4e8ced8ca58ebcef50075ba4e1a93fd54e306089f736cdd3a2236d79b2db0509a7ed4dd4dc9064a8eabb796107f26771fbfb44a17a56b27c891740c73eca3f SHA512 47e0e736db8fcd039b1778296f0dd28bea1c7688bb52c1d7e84bf568050bd058b7569f18f5df6440a9c319558f6397bcc3c35e4c8b261e438220205f96fb44de
DIST meson-docs-0.63.0-40-g280f3423b.tar.gz 77042 BLAKE2B 2724d720ed05b99d933f85039a22a9a46c5f83322aa6ada16023a721828f0063a3cbc74150b6e682a45493f7af3887fb4422bce656827c638d13467b54d69b79 SHA512 119e6b857e109af47044d0a1515d377490f4c4f4b94a4134f642cf1ed5d9ad7ffc99628133ed5fb49d46891469fddb369b8a469f8eb07a903421b48b835a64e3
+DIST muon-0.1.0.tar.gz 472632 BLAKE2B f55fffcc56adc6e84646eae627aa17e3b929f2083d8faf8838ade9f032f23538256dd6f354fc93d3640fd331a2fa98fc42d290f51177b1973883ade3b20b4e34 SHA512 54337fed8ae41bf2dca3cbb0a303a521b7750eb7e5b40ca1aeb0fc045ac82b163d77c7b06a6a790eb3feef6f8d10f2a6b7937f55cfb1404c70b429dd0899dd5f
DIST muon-0_pre20220714.tar.gz 441746 BLAKE2B 22a9c2d1ba76c01553cfd7c13b738f505710df7337f52a0dcbff0779fd0ff01b188994f25f9f31b84d0730d3d88e4334301f1252170ab0258e4cb835924f27d2 SHA512 326424a626788308e608d0c63db39b8d25c493c7f3636ed3fd87c90c8c89800fab231680c18b97c66a9f316cf569a767f9653a4bddd8c57bf5460e7ab9764259
diff --git a/dev-util/muon/muon-0.1.0.ebuild b/dev-util/muon/muon-0.1.0.ebuild
new file mode 100644
index 000000000000..45c2381becbd
--- /dev/null
+++ b/dev-util/muon/muon-0.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit meson python-any-r1
+
+COMMIT_HASH="${PV}"
+MESON_DOCS_TAR=meson-docs-0.63.0-239-g41a05ff93.tar.gz
+
+DESCRIPTION="A meson-compatible build system"
+HOMEPAGE="https://muon.build/"
+SRC_URI="
+ https://git.sr.ht/~lattis/muon/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz
+ man? (
+ https://mochiro.moe/wrap/${MESON_DOCS_TAR}
+ )
+"
+
+# Apache-2.0 for meson-docs
+LICENSE="GPL-3 man? ( Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+archive +curl +libpkgconf +man"
+
+S="${WORKDIR}/${PN}-${COMMIT_HASH}"
+
+DEPEND="
+ curl? ( net-misc/curl )
+ archive? ( app-arch/libarchive:= )
+ libpkgconf? ( dev-util/pkgconf:= )
+ man? ( app-text/scdoc )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ man? (
+ $(python_gen_any_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+python_check_deps() {
+ python_has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ default
+
+ if use man; then
+ mv "${WORKDIR}/meson-docs" "${S}/subprojects" || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature curl libcurl)
+ $(meson_feature archive libarchive)
+ $(meson_feature libpkgconf)
+ $(meson_feature man docs)
+ -Dsamurai=disabled # patched version of samurai downloaded via wraps
+ -Dbestline=enabled # vendored bestline, an insignificant addition
+ )
+ meson_src_configure
+}