summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-20 12:12:54 +0000
committerSam James <sam@gentoo.org>2020-08-20 12:30:44 +0000
commit4b34462e1b49b4b30ed014713f3011d5a246a91e (patch)
tree91ad0896539310099262e57aa9a26ff19829265d
parentdev-python/jedi: Require parso-0.7* (diff)
downloadgentoo-4b34462e.tar.gz
gentoo-4b34462e.tar.bz2
gentoo-4b34462e.zip
media-video/gpac: security bump to 0.8.1
We're bumping to 0.8.1 before 1.0.0 because there was a substantial rewrite. The aim is to stabilise this release first, give 1.0.0 (later commit) a few days in ~arch, then do that. Bug: https://bugs.gentoo.org/711262 Closes: https://bugs.gentoo.org/701538 Closes: https://bugs.gentoo.org/654418 Closes: https://bugs.gentoo.org/658062 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-video/gpac/Manifest1
-rw-r--r--media-video/gpac/files/gpac-0.8.1-configure.patch100
-rw-r--r--media-video/gpac/gpac-0.8.1.ebuild149
3 files changed, 250 insertions, 0 deletions
diff --git a/media-video/gpac/Manifest b/media-video/gpac/Manifest
index ce5adb32da37..8340f361bd62 100644
--- a/media-video/gpac/Manifest
+++ b/media-video/gpac/Manifest
@@ -1 +1,2 @@
DIST gpac-0.7.1.tar.gz 10654838 BLAKE2B 795fd11d6bf02bb0d27d97f2c98017e9875aae26ea7d99c5587c7ec5ccc8273283fbce6444389ff4371a34d0e7d03102982ff8a8ec014c7f0c2ddd36c684cba9 SHA512 0377d9471db9e5ccf75f85dfd0c9f4e37a211108b5e128a5411ac015bd9c906257320d517717f0fa03d434e1fce24bd8a9c3a73200fac5c21b80895b716ab403
+DIST gpac-0.8.1.tar.gz 11432459 BLAKE2B 5c08d6c903b4865c19818c5cee07c0a0ebd1775f168740eadc3722d6b19ed685d4f6089cee4bbd68a52bf7cce4cf564c083deb629c47ba35eac66c754f3136cf SHA512 f2039fe91a502ea8c54330abf893d52d10fb57d4459f5f3aae28122f565ab8964011b67e6af0d79c170fa55b125ac1385fd1d280021da7d1d37b27c74ee5b6c1
diff --git a/media-video/gpac/files/gpac-0.8.1-configure.patch b/media-video/gpac/files/gpac-0.8.1-configure.patch
new file mode 100644
index 000000000000..4a6c97b6cf3a
--- /dev/null
+++ b/media-video/gpac/files/gpac-0.8.1-configure.patch
@@ -0,0 +1,100 @@
+diff --git a/Makefile b/Makefile
+index 61241cd..7481027 100644
+--- a/Makefile
++++ b/Makefile
+@@ -270,7 +270,9 @@ ifeq ($(GPAC_ENST), yes)
+ $(INSTALL) $(INSTFLAGS) -m 644 $(SRC_PATH)/include/gpac/enst/*.h "$(DESTDIR)$(prefix)/include/gpac/enst"
+ endif
+ mkdir -p "$(DESTDIR)$(prefix)/$(libdir)"
++ifeq ($(STATIC_LIBS),yes)
+ $(INSTALL) $(INSTFLAGS) -m 644 "./bin/gcc/libgpac_static.a" "$(DESTDIR)$(prefix)/$(libdir)"
++endif
+ if [ -d $(DESTDIR)$(prefix)/$(libdir)/pkgconfig ] ; then \
+ $(INSTALL) $(INSTFLAGS) -m 644 gpac.pc "$(DESTDIR)$(prefix)/$(libdir)/pkgconfig" ; \
+ fi
+diff --git a/configure b/configure
+index 6ef2258..240b6b0 100755
+--- a/configure
++++ b/configure
+@@ -108,6 +108,7 @@ has_xmlrpc="no"
+ has_openjpeg="no"
+ gprof_build="no"
+ static_build="no"
++static_libs="no"
+ want_pic="no"
+ want_gcov="no"
+ has_joystick="no"
+@@ -266,6 +267,7 @@ GPAC configuration options:
+ --enable-amr-wb enable AMR WB library
+ --enable-amr enable both AMR NB and WB libraries
+ --enable-static-bin link statically against libgpac
++ --enable-static-lib GPAC static libraries build
+ --static-mp4box configure for static linking of MP4Box only.
+ --enable-depth enables depth handling in the compositor
+
+@@ -715,15 +717,6 @@ if docc -lz -Wno-pointer-sign ; then
+ CFLAGS="$CFLAGS -Wno-pointer-sign"
+ fi
+
+-
+-#GCC opt
+-if test "$no_gcc_opt" = "no"; then
+- CFLAGS="-O3 $CFLAGS"
+-else
+- CFLAGS="-O0 $CFLAGS"
+-fi
+-
+-
+ #GCC PIC
+ if test "$cross_prefix" != "" ; then
+ want_pic="no"
+@@ -1931,6 +1924,8 @@ for opt do
+ ;;
+ --enable-static-bin) static_build="yes";
+ ;;
++ --enable-static-lib) static_libs="yes";
++ ;;
+ --disable-ipv6) has_ipv6="no"
+ ;;
+ --disable-wx) has_wx="no"
+@@ -2622,6 +2617,7 @@ echo "** GPAC $version rev$revision Core Configuration **"
+ echo "debug version: $debuginfo"
+ echo "GProf enabled: $gprof_build"
+ echo "Static build enabled: $static_build"
++echo "Static libs enabled: $static_libs"
+ echo "Memory tracking enabled: $use_memory_tracking"
+ echo "Sanitizer enabled: $enable_sanitizer"
+ echo "Fixed-Point Version: $use_fixed_point"
+@@ -3291,6 +3287,7 @@ echo "DEBUGBUILD=$debuginfo" >> config.mak
+ echo "GPROFBUILD=$gprof_build" >> config.mak
+ echo "MP4BOX_STATIC=$static_mp4box" >> config.mak
+ echo "STATICBUILD=$static_build" >> config.mak
++echo "STATICLIBS=$static_libs" >> config.mak
+
+ echo "CONFIG_IPV6=$has_ipv6" >> config.mak
+ if test "$has_ipv6" = "yes" ; then
+diff --git a/src/Makefile b/src/Makefile
+index 935ffff..b3464b7 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -269,16 +269,19 @@ compositor: $(LIBGPAC_COMPOSITOR)
+
+ ifeq ($(CONFIG_DARWIN),yes)
+
++ifeq ($(STATICLIBS),yes)
+ $(LIBTOOL) -s -o ../bin/gcc/libgpac_static.a $(OBJS)
+ $(RANLIB) ../bin/gcc/libgpac_static.a
++endif
+ ifneq ($(STATICBUILD),yes)
+ $(CC) $(SHFLAGS) $(LD_SONAME) -o $@ $(OBJS) $(EXTRALIBS) $(LDFLAGS)
+ endif
+
+ else
+-
++ifeq ($(STATICLIBS), yes)
+ $(AR) cr ../bin/gcc/libgpac_static.a $(OBJS)
+ $(RANLIB) ../bin/gcc/libgpac_static.a
++endif
+ ifneq ($(STATICBUILD),yes)
+ $(CC) $(SHFLAGS) $(LD_SONAME) -o $@ $(OBJS) $(EXTRALIBS) $(LDFLAGS)
+ mv $@ $@.$(VERSION_SONAME)
diff --git a/media-video/gpac/gpac-0.8.1.ebuild b/media-video/gpac/gpac-0.8.1.ebuild
new file mode 100644
index 000000000000..82441609b590
--- /dev/null
+++ b/media-video/gpac/gpac-0.8.1.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == *9999 ]] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/gpac/gpac"
+else
+ SRC_URI="https://github.com/gpac/gpac/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+inherit flag-o-matic toolchain-funcs ${SCM}
+
+DESCRIPTION="Implementation of the MPEG-4 Systems standard developed from scratch in ANSI C"
+HOMEPAGE="https://gpac.wp.imt.fr/ https://github.com/gpac/gpac"
+
+LICENSE="GPL-2"
+# subslot == libgpac major
+SLOT="0/8"
+IUSE="a52 aac alsa debug dvb ffmpeg ipv6 jack jpeg jpeg2k libressl mad opengl oss png
+ pulseaudio sdl ssl static-libs theora truetype vorbis xml xvid X"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ media-libs/libogg
+ a52? ( media-libs/a52dec )
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ ffmpeg? ( media-video/ffmpeg:0= )
+ jack? ( virtual/jack )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:0 )
+ mad? ( media-libs/libmad )
+ opengl? (
+ media-libs/freeglut
+ virtual/glu
+ virtual/opengl
+ )
+ png? ( media-libs/libpng:0= )
+ pulseaudio? ( media-sound/pulseaudio )
+ theora? ( media-libs/libtheora )
+ truetype? ( media-libs/freetype:2 )
+ sdl? ( media-libs/libsdl )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ vorbis? ( media-libs/libvorbis )
+ X? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXv
+ x11-libs/libXext
+ )
+ xml? ( dev-libs/libxml2:2 )
+ xvid? ( media-libs/xvid )
+"
+# disabled upstream, see applications/Makefile
+# wxwidgets? ( =x11-libs/wxGTK-2.8* )
+DEPEND="${RDEPEND}
+ dvb? ( sys-kernel/linux-headers )
+"
+
+# DOCS="AUTHORS BUGS Changelog README.md TODO doc/CODING_STYLE doc/*.doc doc/*.bt doc/SceneGenerators doc/ipmpx_syntax.bt doc/*.txt"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.8.1-configure.patch"
+)
+
+DOCS=(
+ doc/CODING_STYLE
+ doc/GPAC\ UPnP.doc
+ doc/ISO\ 639-2\ codes.txt
+ doc/SceneGenerators
+ doc/ipmpx_syntax.bt
+ Changelog
+ AUTHORS
+ BUGS
+ README.md
+ TODO
+)
+
+HTML_DOCS="doc/*.html"
+
+my_use() {
+ local flag="$1" pflag="${2:-$1}"
+ if use ${flag}; then
+ echo "--use-${pflag}=system"
+ else
+ echo "--use-${pflag}=no"
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:\(--disable-.*\)=\*):\1):" configure || die
+}
+
+src_configure() {
+ tc-export CC CXX AR RANLIB
+
+ local myeconfargs=(
+ --extra-cflags="${CFLAGS}"
+ --cc="$(tc-getCC)"
+ --cxx="$(tc-getCXX)"
+ --libdir="/$(get_libdir)"
+ --verbose
+ --enable-pic
+ --enable-svg
+ --disable-amr
+ --disable-wx
+ --use-js=no
+ --use-ogg=system
+ $(use_enable alsa)
+ $(use_enable debug)
+ $(use_enable dvb dvb4linux)
+ $(use_enable ipv6)
+ $(use_enable jack jack yes)
+ $(use_enable opengl 3d)
+ $(use_enable oss oss-audio)
+ $(use_enable pulseaudio pulseaudio yes)
+ $(use_enable sdl)
+ $(use_enable ssl)
+ $(use_enable static-libs static-lib)
+ $(use_enable X x11)
+ $(use_enable X x11-shm)
+ $(use_enable X x11-xv)
+ $(my_use a52)
+ $(my_use aac faad)
+ $(my_use dvb dvbx)
+ $(my_use ffmpeg)
+ $(my_use jpeg)
+ $(my_use jpeg2k openjpeg)
+ $(my_use mad)
+ $(my_use png)
+ $(my_use theora)
+ $(my_use truetype ft)
+ $(my_use vorbis)
+ $(my_use xvid)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ einstalldocs
+ emake STRIP="true" DESTDIR="${D}" install
+ emake STRIP="true" DESTDIR="${D}" install-lib
+}