summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-27 07:38:10 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-27 09:13:11 +0200
commit4b3d5835727241fd2dc9706505655992848674da (patch)
tree68de0a1887b9ce5ed4df46e74d95f8bb9e3ac0c0
parentdev-lang/go: drop 1.17.7 (diff)
downloadgentoo-4b3d5835.tar.gz
gentoo-4b3d5835.tar.bz2
gentoo-4b3d5835.zip
dev-ruby/posix-spawn: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/posix-spawn/posix-spawn-0.3.15.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-ruby/posix-spawn/posix-spawn-0.3.15.ebuild b/dev-ruby/posix-spawn/posix-spawn-0.3.15.ebuild
deleted file mode 100644
index 98035318b1db..000000000000
--- a/dev-ruby/posix-spawn/posix-spawn-0.3.15.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="README.md TODO HACKING"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Library that implements a subset of the Ruby 1.9 Process::spawn"
-HOMEPAGE="https://github.com/rtomayko/posix-spawn/"
-
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext
- cp ext/*$(get_modname) lib/ || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:.:test -e 'Dir["test/test_*.rb"].each {|f| require f}' || die
-}