summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-28 06:24:53 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-28 06:53:28 -0500
commit4b78f04f21cbfcc3ac3a890dc8955c779c227bd2 (patch)
tree1c3003f62f21088d7b8651059c8a5df8608cc3ee
parentx11-drivers/nvidia-drivers: stabilize 470.94 for amd64 (diff)
downloadgentoo-4b78f04f21cbfcc3ac3a890dc8955c779c227bd2.tar.gz
gentoo-4b78f04f21cbfcc3ac3a890dc8955c779c227bd2.tar.bz2
gentoo-4b78f04f21cbfcc3ac3a890dc8955c779c227bd2.zip
x11-drivers/nvidia-drivers: remove coolbits postinst warning
This is not solved and still happening with 495.46 (doesn't seem like anything can reasonably do about it from a packaging end, and NVIDIA hasn't done anything), but the postinst message itself wasn't shown unless updating 6+ months old nvidia-drivers with coolbits in xorg.conf and is now mostly unused cruft. If this is going to be a permanent state of affair, may be better documented elsewhere and bug closed as an upstream issue (albeit keeping open a bit longer for tracking). Bug: https://bugs.gentoo.org/784248 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.144-r1.ebuild16
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild16
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r1.ebuild16
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild16
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.86-r2.ebuild16
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild16
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-495.44-r2.ebuild16
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild16
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild16
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild16
10 files changed, 0 insertions, 160 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.144-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.144-r1.ebuild
index 1004d1b629b8..2818b9a31cbd 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.144-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.144-r1.ebuild
@@ -402,20 +402,4 @@ pkg_postinst() {
elog "Support for EGLStream (egl-wayland) is no longer offered with legacy"
elog "nvidia-drivers. It is recommended to use nouveau drivers for wayland."
fi
-
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 390.143 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
}
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
index 14c8a94612ac..e2113aa452bb 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.147.ebuild
@@ -407,20 +407,4 @@ pkg_postinst() {
elog "use nvidia-drivers for acceleration without it (e.g. commonly used"
elog "with app-emulation/wine-* or steam). Re-enable if needed."
fi
-
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 390.143 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
}
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r1.ebuild
index 416d84b7d48a..9fff7447aca1 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-460.91.03-r1.ebuild
@@ -417,20 +417,4 @@ pkg_postinst() {
elog "use nvidia-drivers for acceleration without it (e.g. commonly used"
elog "with app-emulation/wine-*). Re-enable if needed."
fi
-
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 460.73.01 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
}
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild
index 3d69f2220850..fd2f86147ae7 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.62.16.ebuild
@@ -430,20 +430,4 @@ pkg_postinst() {
elog "This version of ${PN} only supports EGLStream which is only"
elog "supported by a few wayland compositors (e.g. kwin / mutter, not sway)."
fi
-
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 460.73.01 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
}
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.86-r2.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.86-r2.ebuild
index 6fc46d5276eb..4b35afdaa2c5 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.86-r2.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.86-r2.ebuild
@@ -463,20 +463,4 @@ pkg_postinst() {
elog "If you experience issues, please comment out the option from nvidia.conf."
elog "Of note, may possibly cause issues with SLI and Reverse PRIME."
fi
-
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 460.73.01 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
}
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild
index c0b8c31abf93..8b978b4e3911 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.94.ebuild
@@ -430,20 +430,4 @@ pkg_postinst() {
elog "This version of ${PN} only supports EGLStream which is only"
elog "supported by a few wayland compositors (e.g. kwin / mutter, not sway)."
fi
-
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 460.73.01 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
}
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-495.44-r2.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-495.44-r2.ebuild
index 45f7181d5c6c..cb68478d1349 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-495.44-r2.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-495.44-r2.ebuild
@@ -487,22 +487,6 @@ pkg_postinst() {
elog "Of note, may possibly cause issues with SLI and Reverse PRIME."
fi
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 460.73.01 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
-
ewarn
ewarn "This revision of ${PN} is applying a binary patch to prevent heavy"
ewarn "dbus spamming while using OpenGL. If you experience issues, please try to"
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild
index dd05555ba26e..02a6354ec0a0 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r10.ebuild
@@ -443,22 +443,6 @@ pkg_postinst() {
elog "Of note, may possibly cause issues with SLI and Reverse PRIME."
fi
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 460.73.01 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
-
ewarn
ewarn "This revision of ${PN} is applying a binary patch to prevent heavy"
ewarn "dbus spamming while using OpenGL. If you experience issues, please try to"
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild
index 3e93e2f0a367..5506a22853f2 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46-r20.ebuild
@@ -441,22 +441,6 @@ pkg_postinst() {
elog "Of note, may possibly cause issues with SLI and Reverse PRIME."
fi
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 460.73.01 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
-
ewarn
ewarn "This revision of ${PN} is applying a binary patch to prevent heavy"
ewarn "dbus spamming while using OpenGL. If you experience issues, please try to"
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild
index cf5827d21dcf..f1b40b9e892b 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-495.46.ebuild
@@ -431,20 +431,4 @@ pkg_postinst() {
elog "If you experience issues, either disable wayland or edit nvidia.conf."
elog "Of note, may possibly cause issues with SLI and Reverse PRIME."
fi
-
- # Try to show this message only to users that may really need it
- # given the workaround is discouraged and usage isn't widespread.
- if use X && [[ ${REPLACING_VERSIONS} ]] &&
- ver_test ${REPLACING_VERSIONS} -lt 460.73.01 &&
- grep -qr Coolbits "${EROOT}"/etc/X11/{xorg.conf,xorg.conf.d/*.conf} 2>/dev/null; then
- elog
- elog "Coolbits support with ${PN} has been restricted to require Xorg"
- elog "with root privilege by NVIDIA (being in video group is not sufficient)."
- elog "e.g. attempting to change fan speed with nvidia-settings would fail."
- elog
- elog "Depending on your display manager (e.g. sddm starts X as root, gdm doesn't)"
- elog "or if using startx, it may be necessary to emerge x11-base/xorg-server with"
- elog 'USE="suid -elogind -systemd" if wish to keep using this feature.'
- elog "Bug: https://bugs.gentoo.org/784248"
- fi
}