summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-24 12:19:00 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-24 12:25:56 -0400
commit4b9aeb321da82a48bd45b8018390a1236a7bb888 (patch)
treee057061029725cc2a65cf13fe477273d7b6a83a9
parentx11-libs/libdrm: Drop old versions (diff)
downloadgentoo-4b9aeb32.tar.gz
gentoo-4b9aeb32.tar.bz2
gentoo-4b9aeb32.zip
x11-libs/libxcb: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libxcb/Manifest1
-rw-r--r--x11-libs/libxcb/files/libxcb-1.14-tests-don-t-use-deprecated-fail_unless-check-API.patch86
-rw-r--r--x11-libs/libxcb/libxcb-1.14.ebuild58
3 files changed, 0 insertions, 145 deletions
diff --git a/x11-libs/libxcb/Manifest b/x11-libs/libxcb/Manifest
index 8ea9468f9062..345b1fd64638 100644
--- a/x11-libs/libxcb/Manifest
+++ b/x11-libs/libxcb/Manifest
@@ -1,2 +1 @@
-DIST libxcb-1.14.tar.xz 439404 BLAKE2B 63605e02dd32b4d26b3ac6d3b93b7383dbc30701b9a063e8efa5b387215c9325196451f80c7b0b357df1773c6fd1224eea8eeca2a456055a2cdc61082c726111 SHA512 b90a23204b0d2c29d8b115577edb01df0465e02d6a8876550fecd62375d24a5d5f872ddd5946772ddba077cadce75b12c7a6d218469dc30b5b92bc82188e8bc6
DIST libxcb-1.15.tar.xz 446492 BLAKE2B d50146ee9b822dfd0c24513110e1706cda05ce588f276005167a911d3097275f36be1ce755c42c2b2970e750f10b2b943f3e373b6e55865fba986e29811a3545 SHA512 f6c7d766b7cf9cab6abe948ee424cbae6951dbfe2f76fa58a109cdc05b0f0919dcc4e38176a22ff4b95fc1e38596115317e32ba33b24cae0035a4e30dbcbdad9
diff --git a/x11-libs/libxcb/files/libxcb-1.14-tests-don-t-use-deprecated-fail_unless-check-API.patch b/x11-libs/libxcb/files/libxcb-1.14-tests-don-t-use-deprecated-fail_unless-check-API.patch
deleted file mode 100644
index cc7f22ba4e9d..000000000000
--- a/x11-libs/libxcb/files/libxcb-1.14-tests-don-t-use-deprecated-fail_unless-check-API.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-From f01f3c378eb0168fbb055c7be1c2d08a7acd3752 Mon Sep 17 00:00:00 2001
-From: Ran Benita <ran@unusedvar.com>
-Date: Tue, 17 Nov 2020 23:43:06 +0200
-Subject: [PATCH] tests: don't use deprecated fail_unless check API
-
-It causes errors like this when running make check:
-
-check_public.c:40:24: error: too many arguments for format [-Werror=format-extra-args]
- 40 | fail_unless(success, "unexpected parse failure %sfor '%s'", test_string[test_type], name);
-
-Closes: https://gitlab.freedesktop.org/xorg/lib/libxcb/-/issues/49
-Tested-by: Matt Turner <mattst88@gmail.com>
-Signed-off-by: Ran Benita <ran@unusedvar.com>
----
- configure.ac | 2 +-
- tests/check_public.c | 30 +++++++++++++++---------------
- 2 files changed, 16 insertions(+), 16 deletions(-)
-
-diff --git a/tests/check_public.c b/tests/check_public.c
-index 2094bfe..aed40c8 100644
---- a/tests/check_public.c
-+++ b/tests/check_public.c
-@@ -37,18 +37,18 @@ static void parse_display_pass(const char *name, const char *host, const int dis
- got_display = got_screen = -42;
- mark_point();
- success = xcb_parse_display(argument, &got_host, &got_display, &got_screen);
-- fail_unless(success, "unexpected parse failure %sfor '%s'", test_string[test_type], name);
-- fail_unless(strcmp(host, got_host) == 0, "parse %sproduced unexpected hostname '%s' for '%s': expected '%s'", test_string[test_type], got_host, name, host);
-- fail_unless(display == got_display, "parse %sproduced unexpected display '%d' for '%s': expected '%d'", test_string[test_type], got_display, name, display);
-- fail_unless(screen == got_screen, "parse %sproduced unexpected screen '%d' for '%s': expected '%d'", test_string[test_type], got_screen, name, screen);
-+ ck_assert_msg(success, "unexpected parse failure %sfor '%s'", test_string[test_type], name);
-+ ck_assert_msg(strcmp(host, got_host) == 0, "parse %sproduced unexpected hostname '%s' for '%s': expected '%s'", test_string[test_type], got_host, name, host);
-+ ck_assert_msg(display == got_display, "parse %sproduced unexpected display '%d' for '%s': expected '%d'", test_string[test_type], got_display, name, display);
-+ ck_assert_msg(screen == got_screen, "parse %sproduced unexpected screen '%d' for '%s': expected '%d'", test_string[test_type], got_screen, name, screen);
-
- got_host = (char *) -1;
- got_display = got_screen = -42;
- mark_point();
- success = xcb_parse_display(argument, &got_host, &got_display, 0);
-- fail_unless(success, "unexpected screenless parse failure %sfor '%s'", test_string[test_type], name);
-- fail_unless(strcmp(host, got_host) == 0, "screenless parse %sproduced unexpected hostname '%s' for '%s': expected '%s'", test_string[test_type], got_host, name, host);
-- fail_unless(display == got_display, "screenless parse %sproduced unexpected display '%d' for '%s': expected '%d'", test_string[test_type], got_display, name, display);
-+ ck_assert_msg(success, "unexpected screenless parse failure %sfor '%s'", test_string[test_type], name);
-+ ck_assert_msg(strcmp(host, got_host) == 0, "screenless parse %sproduced unexpected hostname '%s' for '%s': expected '%s'", test_string[test_type], got_host, name, host);
-+ ck_assert_msg(display == got_display, "screenless parse %sproduced unexpected display '%d' for '%s': expected '%d'", test_string[test_type], got_display, name, display);
- }
- putenv("DISPLAY=");
- }
-@@ -79,18 +79,18 @@ static void parse_display_fail(const char *name)
- got_display = got_screen = -42;
- mark_point();
- success = xcb_parse_display(argument, &got_host, &got_display, &got_screen);
-- fail_unless(!success, "unexpected parse success %sfor '%s'", test_string[test_type], name);
-- fail_unless(got_host == (char *) -1, "host changed on parse failure %sfor '%s': got %p", test_string[test_type], name, got_host);
-- fail_unless(got_display == -42, "display changed on parse failure %sfor '%s': got %d", test_string[test_type], name, got_display);
-- fail_unless(got_screen == -42, "screen changed on parse failure %sfor '%s': got %d", test_string[test_type], name, got_screen);
-+ ck_assert_msg(!success, "unexpected parse success %sfor '%s'", test_string[test_type], name);
-+ ck_assert_msg(got_host == (char *) -1, "host changed on parse failure %sfor '%s': got %p", test_string[test_type], name, got_host);
-+ ck_assert_msg(got_display == -42, "display changed on parse failure %sfor '%s': got %d", test_string[test_type], name, got_display);
-+ ck_assert_msg(got_screen == -42, "screen changed on parse failure %sfor '%s': got %d", test_string[test_type], name, got_screen);
-
- got_host = (char *) -1;
- got_display = got_screen = -42;
- mark_point();
- success = xcb_parse_display(argument, &got_host, &got_display, 0);
-- fail_unless(!success, "unexpected screenless parse success %sfor '%s'", test_string[test_type], name);
-- fail_unless(got_host == (char *) -1, "host changed on parse failure %sfor '%s': got %p", test_string[test_type], name, got_host);
-- fail_unless(got_display == -42, "display changed on parse failure %sfor '%s': got %d", test_string[test_type], name, got_display);
-+ ck_assert_msg(!success, "unexpected screenless parse success %sfor '%s'", test_string[test_type], name);
-+ ck_assert_msg(got_host == (char *) -1, "host changed on parse failure %sfor '%s': got %p", test_string[test_type], name, got_host);
-+ ck_assert_msg(got_display == -42, "display changed on parse failure %sfor '%s': got %d", test_string[test_type], name, got_display);
- }
- putenv("DISPLAY=");
- }
-@@ -183,7 +183,7 @@ END_TEST
-
- static void popcount_eq(uint32_t bits, int count)
- {
-- fail_unless(xcb_popcount(bits) == count, "unexpected popcount(%08x) != %d", bits, count);
-+ ck_assert_msg(xcb_popcount(bits) == count, "unexpected popcount(%08x) != %d", bits, count);
- }
-
- START_TEST(popcount)
---
-2.26.2
-
diff --git a/x11-libs/libxcb/libxcb-1.14.ebuild b/x11-libs/libxcb/libxcb-1.14.ebuild
deleted file mode 100644
index 8cd1a7ed1915..000000000000
--- a/x11-libs/libxcb/libxcb-1.14.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE=xml
-
-XORG_TARBALL_SUFFIX="xz"
-XORG_MULTILIB=yes
-XORG_DOC=doc
-
-inherit python-any-r1 xorg-3
-
-DESCRIPTION="X C-language Bindings library"
-HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb"
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc selinux test +xkb"
-RESTRICT="!test? ( test )"
-SLOT="0/1.12"
-
-RDEPEND="
- >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
- >=x11-libs/libXdmcp-1.1.1-r1[${MULTILIB_USEDEP}]
-"
-DEPEND="${RDEPEND}
- >=x11-base/xcb-proto-1.14[${MULTILIB_USEDEP}]
- elibc_Darwin? ( dev-libs/libpthread-stubs )
- test? ( dev-libs/check[${MULTILIB_USEDEP}] )
-"
-# Note: ${PYTHON_USEDEP} needs to go verbatim
-BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep '>=x11-base/xcb-proto-1.14[${PYTHON_USEDEP}]')
- doc? ( app-doc/doxygen[dot] )
- test? ( dev-libs/libxslt )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-tests-don-t-use-deprecated-fail_unless-check-API.patch
-)
-
-python_check_deps() {
- has_version -b ">=x11-base/xcb-proto-1.14[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
- xorg-3_pkg_setup
-}
-
-src_configure() {
- local XORG_CONFIGURE_OPTIONS=(
- $(use_enable doc devel-docs)
- $(use_enable selinux)
- )
- xorg-3_src_configure
-}