summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-11-15 01:30:25 -0600
committerMatthias Maier <tamiko@gentoo.org>2015-11-15 01:46:13 -0600
commit4b9af846b69fddc4708c2bd0a49d77a49212e6f3 (patch)
tree03ac9ce6dc84cab8f8b6c7525fe7d443ed17c5ef
parentapp-emulation/spice-protocol: version bump to 0.12.10 (diff)
downloadgentoo-4b9af846b69fddc4708c2bd0a49d77a49212e6f3.tar.gz
gentoo-4b9af846b69fddc4708c2bd0a49d77a49212e6f3.tar.bz2
gentoo-4b9af846b69fddc4708c2bd0a49d77a49212e6f3.zip
app-emulation/spice: version bump to 0.12.6 (CVE-2015-5260, CVE-2015-5260)
- Bump to latest version that fixes to security issues. - Introduce libressl support Bugs: 545180 Bugs: 560006 Bugs: 562890 Bugs: 565250 Package-Manager: portage-2.2.23
-rw-r--r--app-emulation/spice/Manifest1
-rw-r--r--app-emulation/spice/spice-0.12.6.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/app-emulation/spice/Manifest b/app-emulation/spice/Manifest
index f77be293b65e..fe059373a51c 100644
--- a/app-emulation/spice/Manifest
+++ b/app-emulation/spice/Manifest
@@ -1 +1,2 @@
DIST spice-0.12.5.tar.bz2 1737169 SHA256 4209a20d8f67cb99a8a6ac499cfe79a18d4ca226360457954a223d6795c2f581 SHA512 1501c913ba3b1856444536a9bfda7a2138a96088f940b483e963df342b91deb945d77bfb3c83ebddfcd7c3008695c0dd7df30ff9fd8502cbbcac1c610a273572 WHIRLPOOL 8f50a91febb0d2279ac867ae31cb14f996106625f0f26ba1bb8b5b576eedce6839f52c70e19a03f03be209f695c36b3ba1d94fadee6c9f134e2afffd5b99c476
+DIST spice-0.12.6.tar.bz2 1181088 SHA256 f148ea30135bf80a4f465ce723a1cd6d4ccb34c098b6298a020b378ace8569b6 SHA512 877d9c447a09055c61db7839ae1a2bbd97ab1178d8fd30fff83883064f8a2f269479649e696732095833ed3fda2d0cc0cbe2a420decb89d36d2cf2f18ad9a3db WHIRLPOOL e381cf469a29be9a91ab442ee5f426a44ee569528d9297401df1c927cbf558e9daee7709cd69a4cc6389481b0c5aa26b19e56f0e97576e270d768842581544fe
diff --git a/app-emulation/spice/spice-0.12.6.ebuild b/app-emulation/spice/spice-0.12.6.ebuild
new file mode 100644
index 000000000000..1ef8d8b6e5eb
--- /dev/null
+++ b/app-emulation/spice/spice-0.12.6.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit eutils python-any-r1
+
+DESCRIPTION="SPICE server and client"
+HOMEPAGE="http://spice-space.org/"
+SRC_URI="http://spice-space.org/download/releases/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="client libressl sasl smartcard static-libs" # static
+
+# only the client links against libcacard, the libspice-server only uses the headers
+# the client cannot be built statically since alsa and qemu[smartcard] are missing static-libs
+RDEPEND="
+ >=dev-libs/glib-2.22:2[static-libs(+)?]
+ >=media-libs/celt-0.5.1.1:0.5.1[static-libs(+)?]
+ media-libs/opus[static-libs(+)?]
+ sys-libs/zlib[static-libs(+)?]
+ virtual/jpeg:0=[static-libs(+)?]
+ >=x11-libs/pixman-0.17.7[static-libs(+)?]
+ !libressl? ( dev-libs/openssl:0[static-libs(+)?] )
+ libressl? ( dev-libs/libressl[static-libs(+)?] )
+ sasl? ( dev-libs/cyrus-sasl[static-libs(+)?] )
+ client? (
+ media-libs/alsa-lib
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/libXinerama-1.0
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ smartcard? ( app-emulation/qemu[smartcard] )
+ )"
+
+DEPEND="
+ >=app-emulation/spice-protocol-0.12.10
+ virtual/pkgconfig
+ $(python_gen_any_dep \
+ '>=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]')
+ smartcard? ( app-emulation/qemu[smartcard] )
+ ${RDEPEND}"
+
+python_check_deps() {
+ has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && python-any-r1_pkg_setup
+}
+
+# maintainer notes:
+# * opengl support is currently broken
+
+src_prepare() {
+ epatch "${FILESDIR}/0.11.0-gold.patch"
+
+ epatch_user
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable client) \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ --disable-gui \
+ --disable-static-linkage
+# $(use_enable static static-linkage) \
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}