summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 17:12:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 17:12:54 +0200
commit4bb80a001a41f3d24a4d53eccbf588a180c8a3ba (patch)
tree827685310cd452c59f74fa007f9a2d386b1cc2fe
parentdev-ros/rosapi: Initial import. Ebuild by me. (diff)
downloadgentoo-4bb80a001a41f3d24a4d53eccbf588a180c8a3ba.tar.gz
gentoo-4bb80a001a41f3d24a4d53eccbf588a180c8a3ba.tar.bz2
gentoo-4bb80a001a41f3d24a4d53eccbf588a180c8a3ba.zip
dev-ros/rosauth: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
-rw-r--r--dev-ros/rosauth/Manifest1
-rw-r--r--dev-ros/rosauth/metadata.xml5
-rw-r--r--dev-ros/rosauth/rosauth-0.1.7.ebuild23
-rw-r--r--dev-ros/rosauth/rosauth-9999.ebuild23
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-ros/rosauth/Manifest b/dev-ros/rosauth/Manifest
new file mode 100644
index 000000000000..d6853764c6ec
--- /dev/null
+++ b/dev-ros/rosauth/Manifest
@@ -0,0 +1 @@
+DIST rosauth-0.1.7.tar.gz 6060 SHA256 c85c4163c94d20bce9864180785210bfe3dfd110114f18212bd711d1be87c48e SHA512 c52317cd173ec655b779f96ffe324cd136a54168484f26fff2a0d9fe2da6e25cc5109f1905d7528a9f6a433287873b63c53f96ec425ca6af740d4eea0b3250b5 WHIRLPOOL 9a21f936bea44735f3dbaf413cb9fbd93f7d673e186f99f7c7eff284d3187c44d096c1635a094cd35ce04a0909558ae174b16bb3a5d3ffe19022f655a8bc9238
diff --git a/dev-ros/rosauth/metadata.xml b/dev-ros/rosauth/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosauth/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosauth/rosauth-0.1.7.ebuild b/dev-ros/rosauth/rosauth-0.1.7.ebuild
new file mode 100644
index 000000000000..ff0731f53943
--- /dev/null
+++ b/dev-ros/rosauth/rosauth-0.1.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Server Side tools for Authorization and Authentication of ROS Clients"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/rosauth/rosauth-9999.ebuild b/dev-ros/rosauth/rosauth-9999.ebuild
new file mode 100644
index 000000000000..ff0731f53943
--- /dev/null
+++ b/dev-ros/rosauth/rosauth-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Server Side tools for Authorization and Authentication of ROS Clients"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"