summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-14 07:39:40 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-14 07:47:52 +0200
commit4bbab63820e27fabfcb521667850a01fd47254d8 (patch)
tree646c44d669ba62e18ea9a1c2a1a3617ccf91203c
parentwww-plugins/adobe-flash: Old (diff)
downloadgentoo-4bbab63820e27fabfcb521667850a01fd47254d8.tar.gz
gentoo-4bbab63820e27fabfcb521667850a01fd47254d8.tar.bz2
gentoo-4bbab63820e27fabfcb521667850a01fd47254d8.zip
net-analyzer/wireshark: Inherit python-any-r1 instead of python-r1
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Bug: https://bugs.gentoo.org/691464 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
-rw-r--r--net-analyzer/wireshark/wireshark-3.1.0.ebuild5
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild5
2 files changed, 4 insertions, 6 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.1.0.ebuild b/net-analyzer/wireshark/wireshark-3.1.0.ebuild
index ac253458192d..cb28f93ddffa 100644
--- a/net-analyzer/wireshark/wireshark-3.1.0.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit fcaps flag-o-matic multilib python-r1 qmake-utils user xdg-utils cmake-utils
+inherit fcaps flag-o-matic multilib python-any-r1 qmake-utils user xdg-utils cmake-utils
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -82,7 +82,6 @@ RDEPEND="
selinux? ( sec-policy/selinux-wireshark )
"
REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
plugin_ifdemo? ( plugins )
"
PATCHES=(
@@ -119,7 +118,7 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
- python_setup 'python3*'
+ python_setup
mycmakeargs+=(
$(use androiddump && use pcap && echo -DEXTCAP_ANDROIDDUMP_LIBPCAP=yes)
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index d85aa0a5e072..a4453c74df19 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit fcaps flag-o-matic git-r3 multilib python-r1 qmake-utils user xdg-utils cmake-utils
+inherit fcaps flag-o-matic git-r3 multilib python-any-r1 qmake-utils user xdg-utils cmake-utils
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -82,7 +82,6 @@ RDEPEND="
selinux? ( sec-policy/selinux-wireshark )
"
REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
plugin_ifdemo? ( plugins )
"
PATCHES=(
@@ -119,7 +118,7 @@ src_configure() {
append-cxxflags -fPIC -DPIC
fi
- python_setup 'python3*'
+ python_setup
mycmakeargs+=(
$(use androiddump && use pcap && echo -DEXTCAP_ANDROIDDUMP_LIBPCAP=yes)