summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-17 21:25:46 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-17 21:25:46 +0300
commit4bc32113d0754aa836d670b5f5c6407377b565be (patch)
tree8b29461621226f71f5e441003a63b9bab3cf8b71
parentdev-python/Faker: add 14.1.0 (diff)
downloadgentoo-4bc32113.tar.gz
gentoo-4bc32113.tar.bz2
gentoo-4bc32113.zip
dev-python/cwcwidth: add 0.1.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/cwcwidth/Manifest1
-rw-r--r--dev-python/cwcwidth/cwcwidth-0.1.7.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/cwcwidth/Manifest b/dev-python/cwcwidth/Manifest
index 6905a913a95e..8420e0c49562 100644
--- a/dev-python/cwcwidth/Manifest
+++ b/dev-python/cwcwidth/Manifest
@@ -1 +1,2 @@
DIST cwcwidth-0.1.6.gh.tar.gz 11563 BLAKE2B 014c1ae377005c704620fda7063e9891c014bb3f3f22160baf55cbef6e07084302a34ccea6bce2ca0f06d193ed3782006e308930a19c9a3c02bf181070eb5654 SHA512 0516fd49d625cd4bec26c27fd2fbbde55ca13a92bee3712018627a5c7f7a0c04aa06842ecce4c99d468f262a829f4ec5ff20bbc66232ad0fc037a7ade5845622
+DIST cwcwidth-0.1.7.gh.tar.gz 11282 BLAKE2B 20be2d54aceabc02a12fadc0cdee6e53037480fcc01be3b08b0ec69ccd515cdbe91a9024ea29e6dbd0d4c927ae0a32dd7debcc07815a9f2053a9ef6a5d5a0d7b SHA512 b81b1ccdce44e8e11d55258752a20e25a76452b3f0324e6168d89a5dfce706e0dd9dd28096234fcea4c38f619a41518dd7fe249552f7e27f77d383074001e468
diff --git a/dev-python/cwcwidth/cwcwidth-0.1.7.ebuild b/dev-python/cwcwidth/cwcwidth-0.1.7.ebuild
new file mode 100644
index 000000000000..b667006da87e
--- /dev/null
+++ b/dev-python/cwcwidth/cwcwidth-0.1.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for wc(s)width"
+HOMEPAGE="
+ https://github.com/sebastinas/cwcwidth/
+ https://pypi.org/project/cwcwidth/"
+SRC_URI="
+ https://github.com/sebastinas/cwcwidth/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd tests || die
+ distutils-r1_src_test
+}